Results 1 to 4 of 4

Thread: Gas Gauge Failure?

  1. #1
    Junior Member
    Join Date
    May 2017
    Posts
    2
    Post Thanks / Like

    Gas Gauge Failure?

    I have a 2000 Vanden Plas and the fuel gauge constantly reads empty with the low fuel light on. It was not working when I purchased the car, so I figured it was just a bad sending unit. I bought a new sending unit and replaced it properly, but the gauge still doesn't work. I know the sending unit is good, but I'm just wondering what else could be the possible cause for this? My only thought could be a faulty gauge cluster, maybe not plugged in in the back? In that case, the range portion of the trip computer would work, but as of now, it reads error. Any help or ideas would be appreciated. Thanks.

  2. #2
    Senior Member Andy K's Avatar
    Join Date
    Oct 2008
    Location
    UK
    Posts
    2,577
    Post Thanks / Like
    Dash or wire broken between tank and dash.

    Plugs are at the front of the dash and easy to get to

  3. #3
    Junior Member
    Join Date
    May 2017
    Posts
    2
    Post Thanks / Like
    I removed the cluster today to see if there was some faulty wiring or perhaps the needle is stuck. Everything seemed to be plugged in and the needle moved just fine when I gave it a push. I'm not sure what else it could be aside from a faulty wire. The first 15 seconds that the car is on, the range gives a mile reading and then reads error. Perhaps there is a relay at fault, or something else that I don't know about...

  4. #4
    Senior Member Andy K's Avatar
    Join Date
    Oct 2008
    Location
    UK
    Posts
    2,577
    Post Thanks / Like
    Interesting, that there are two wires for the gauge, rather than using a ground on the tank.

    Red/white
    and
    black?/white
    wires

    pins 13 & 14 on dash

    900R for empty
    80R for full.

    try shorting the two wires together at the tank end and/or dash end and see if the gauge briefly goes high.

    or if it is still won't move get yourself an 82R resistor
    XJR 2001 Pacific Blue
    Range Rover Sport 2005 Red 2.7 TD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •