Results 1 to 3 of 3

Thread: Series 3 hazard switch replacement issues

  1. #1
    Junior Member
    Join Date
    Aug 2017
    Post Thanks / Like

    Series 3 hazard switch replacement issues

    Hi, my hazard switch was broken so I swapped out a new one. It worked becore, broken cover and all, but now it doesn't. I have no power to the brown/orange wire that shoukd be hot all the time. Jag-lovers says this line is fused from the battery but I can't find the fuse. Any ideas? Cheers.
    Directional indicators do not work, and the dip switch just stopped too. Seems l ike these are connected to the same issue.

  2. #2
    Senior Member
    Join Date
    Apr 2017
    Post Thanks / Like
    There are 2 fuses that feed the hazard switch, #2 & #10 both 15Amps. #2 is always live but #10 is live when ignition key in position II.
    If both fuses are blown, it means you have a short circuit on the bulb side / harness or the flasher relay.
    I would start by removing the flasher relay, then replacing the fuses while the relay is out.
    Download the diagram below and print page 19 FIG 7.1 this will help a lot.

    You will be only guessing without the electrical diagram.
    Good luck...

  3. #3
    Senior Member
    Join Date
    Apr 2007
    Post Thanks / Like
    you need to disconnect the battery when working with electricals.

    many times the new switches don't match the old wiring.

    I can't post much because the ads freeze my computer and I cannot turn the dammed ads off!
    1965 Jaguar 3.8 'S'
    1984 Jaguar XJ-6 4.2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts