Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: XK8 intermittent electrical faults

  1. #11
    Member
    Join Date
    Oct 2012
    Location
    Arlington, VA USA
    Posts
    88
    Post Thanks / Like
    Also the crimp in the braided battery ground cable is know to go bad intermittently causing this type of issue.
    www.thejagwrangler.com
    2001 XKR
    White Onyx convertible, S-type 4.2 Quartz sedan., 2007 XK Ebony Convertible

  2. #12
    Senior Member
    Join Date
    Jul 2014
    Location
    Telford
    Posts
    211
    Post Thanks / Like
    So does the crimp on the + cable.
    Quick way to test is to start the car, and then while running, touch the crimp, if warm it is going to cause trouble. Also volt drop is easily checked with a voltmeter.
    On mine, it was used for a short commute for 4 days, day 5 would not start- low battery. 0.7V drop in the crimp.
    2000 XK8 convertible, 2004 X-type Diesel.

  3. #13
    Member noizyboy's Avatar
    Join Date
    Jul 2011
    Location
    Bedfordshire
    Posts
    64
    Post Thanks / Like
    Hi all and thanks again for the input. The car has been with E&E in Milton Keynes. Very helpful and knowledgeable. I managed to get a repeat of the fault, but it cleared itself again, so left it in the workshop. After about a week they managed to get the fault up again and diagnosed it as a faulty instrument pack (speedo etc). They have fitted a secondhand unit which seems to have cured the problem. Only trouble is the mileage is now 135000 whereas the car is on about 78000. The garage has fully documented the change (in the service book and on the bill).

    Does anyone know if it’s possible to get the mileage adjusted?

  4. #14
    Senior Member Nerja's Avatar
    Join Date
    Mar 2015
    Posts
    461
    Post Thanks / Like
    Quote Originally Posted by noizyboy View Post
    Hi all and thanks again for the input. The car has been with E&E in Milton Keynes. Very helpful and knowledgeable. I managed to get a repeat of the fault, but it cleared itself again, so left it in the workshop. After about a week they managed to get the fault up again and diagnosed it as a faulty instrument pack (speedo etc). They have fitted a secondhand unit which seems to have cured the problem. Only trouble is the mileage is now 135000 whereas the car is on about 78000. The garage has fully documented the change (in the service book and on the bill).

    Does anyone know if it’s possible to get the mileage adjusted?
    I'm sure you can get the mileage adjusted. Just google Jaguar XK8 mileage correction and find someone local who can do it.

  5. #15
    Member noizyboy's Avatar
    Join Date
    Jul 2011
    Location
    Bedfordshire
    Posts
    64
    Post Thanks / Like
    Ok found a specialist who says they can do it. However they say they need to lift a 64 pin chip from the board, and inject a voltage. There is a risk it could damage the board, chip, or both. Anyone else done this?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •