Results 1 to 4 of 4

Thread: Fuel Pump for 1961 Mark 2 2.4 engine

  1. #1
    Junior Member
    Join Date
    Nov 2017
    Location
    Gilroy, California USA
    Posts
    2
    Post Thanks / Like

    Question Fuel Pump for 1961 Mark 2 2.4 engine

    I recently inherited this Mark 2 and am in the process of fixing a few things, IE the carburetors. At present when I Start up my vehicle it starts up immediately, but the engine races to 4000 rpms and stays there. My carbs do leak petrol, so I will have these rebuilt. No matter what I set the Idle speed at low or high or the petrol volume, it still races. Can anyone help with an idea of why my engine is racing at startup and won’t return to proper idle speed. Is it the Carbs or the fuel pump? If anyone could give me some input I would greatly appreciate the help.

  2. #2
    Super Moderator Ian D's Avatar
    Join Date
    Nov 2008
    Location
    Hampshire
    Posts
    6,539
    Post Thanks / Like
    Welcome to the forum!

    Thread moved to mk2 section.
    Current Car:
    2017 XE R-Sport 25t 250Ps 18MY.

    Previous Cars:
    2000 S-Type 3.0L SE Auto
    2004 X-Type 3.0L AWD SE Auto estate.
    2007 XK x150 4.2L Coupe

    Resident Super Moderator.
    V6 X-Type Oil Sump Replacement Guide


  3. #3
    Senior Member
    Join Date
    Apr 2008
    Location
    Further up the creek.
    Posts
    595
    Post Thanks / Like
    Nothing to do with the fuel pump.

    If it's actually racing up to 4000 RPM and staying there, then this is a throttle issue. It must be sticking open. It may not be sticking open a lot (maybe 1/4 throttle) but that would be enough in a no-load situation to rev up that much.

    So it's all easy to check. Indeed disconnect the carburettors from the gas pedal and make sure the butterflies are completely closed. Then fire it up.
    2000 Jaguar X308 4.0
    1973 Jensen Interceptor Mk III 7.2
    1969 Jensen Interceptor Mk I 6.3

  4. #4
    Junior Member
    Join Date
    Nov 2017
    Location
    Gilroy, California USA
    Posts
    2
    Post Thanks / Like

    Thanks for the reply. I will check that out.

    Quote Originally Posted by SV8Predator View Post
    Nothing to do with the fuel pump.

    If it's actually racing up to 4000 RPM and staying there, then this is a throttle issue. It must be sticking open. It may not be sticking open a lot (maybe 1/4 throttle) but that would be enough in a no-load situation to rev up that much.

    So it's all easy to check. Indeed disconnect the carburettors from the gas pedal and make sure the butterflies are completely closed. Then fire it up.



    Thanks for the reply. I will check that out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •