Results 1 to 9 of 9

Thread: no crank

  1. #1
    Senior Member
    Join Date
    Jan 2011
    Location
    W.Midlands
    Posts
    136
    Post Thanks / Like

    no crank

    Just had car back from having starter motor replaced.
    I made a few trips totalling 50 odd miles before locking
    it with the key for the night.
    Having to take my wife to a hospital appointment this morning,
    I duly went out to warm her up prior to the short trip but after
    unlocking with the key and switching on the ignition, I found there
    was no cranking .
    I then checked with my old local garage (just moved house) and
    was told the key needed re-programming -co-incidence or is it
    starter related ?
    John

  2. #2
    Senior Member
    Join Date
    Jul 2007
    Location
    Hertfordshire
    Posts
    2,555
    Post Thanks / Like
    Very unlikely to be the key needing re-programming.

    However, if that is the problem, it will cause the red light by the handbrake (the immobiliser light) to flash about 1 minute after turning on the ignition.

    Is the car battery good?

    Jim
    (EX) '06 2.0D SE Estate

  3. #3
    Senior Member Jimbov8's Avatar
    Join Date
    Apr 2013
    Location
    Worksop
    Posts
    10,485
    Post Thanks / Like
    Could be you have a drain on the battery or the ignition switch maybe faulty.
    Jim.
    2009 XK 5.0L PortfolioPast:-87'XJS 3.6L, 93'XJ40 3.2L gold, 95'XJ6 4.0L sport, 00'XJ8 3.2L sport, 2005 XK8 4.2L coupe in that order and enjoyed all of 'em.

    I do not offer advice, I only say what I would do with the set of circumstances presented. Your choice always.

  4. #4
    Senior Member Spudgun!'s Avatar
    Join Date
    Oct 2017
    Location
    Devon
    Posts
    165
    Post Thanks / Like
    Stupid question, but I'm going to ask it.

    Is your car an automatic?
    2002 2.1SE.
    Retro fitted CD changer, GSM phone, Voice Control and Sat Nav.

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Location
    W.Midlands
    Posts
    136
    Post Thanks / Like

    No cranking

    Quote Originally Posted by Spudgun! View Post
    Stupid question, but I'm going to ask it.

    Is your car an automatic?
    Hi guys, thanks for the input.
    Not auto
    Battery on top line -5 mins charge and shows green and new last year anyway.
    Do you mean on the programming fault that the light should stay on for 1 minute or
    come back on after 1 minute please ?
    ta
    John

  6. #6
    Senior Member johnw777's Avatar
    Join Date
    Feb 2016
    Location
    Southend on Sea, ESSEX
    Posts
    535
    Post Thanks / Like
    Has the small actuating wire come off the starter?
    Normally a spade connector.
    2005 2.2 D Estate

  7. #7
    Senior Member
    Join Date
    Jan 2011
    Location
    W.Midlands
    Posts
    136
    Post Thanks / Like
    Hi John - actually, that is my suspicion but wanted to rule out
    everything else so my "new" local garage don't try it on ??

  8. #8
    Senior Member
    Join Date
    Jul 2007
    Location
    Hertfordshire
    Posts
    2,555
    Post Thanks / Like
    Quote Originally Posted by Theregistrar View Post
    Do you mean on the programming fault that the light should stay on for 1 minute or
    come back on after 1 minute please ?
    ta
    If there is a programming/immobilser error, the light will either rapidly flash on ignition switch on or after a minute of switch on will start to flash a repeating 2 digit code eg 2 flashes, pause, 3 flashes long pause, 2 flashes, pause etc (this example meaning code 23).

    If the light goes out soon after ignition on and stays out, then the key programming (immobiliser) has passed it's security test.

    Jim
    (EX) '06 2.0D SE Estate

  9. #9
    Senior Member Sean O''s Avatar
    Join Date
    Dec 2016
    Location
    Bingley West Yorkshire.
    Posts
    905
    Post Thanks / Like
    I'd be checking the connections at the starter motor, or the battery terminals are tight. Just because you have a charged battery doesn't mean the charge is getting to the starter motor.

    If the key passes the flash test on the immobiliser that is working ok.

    Do you have a spare key you can try?
    2007 X-Type Saloon sport 2.5 AWD in Black.

    2010 Zafira Elite 1.9 CDTI (with the chocolate M32 Box)

    20 years experience with motor vehicle engineering.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •