Results 1 to 4 of 4

Thread: DTC Problem

  1. #1
    Junior Member
    Join Date
    Jan 2017
    Posts
    1
    Post Thanks / Like

    DTC Problem

    Hi . Thanks for allowing me to join the forum.
    I currenlty have a DTC issue with my car,

    2001 X308
    4,0 Litre
    The DTC issue is a strange one,
    I am using a iCarsoft 930 (Landrover & Jaguar)

    Ok, the issue, reduced performance light is on.
    I plug the code reader in,
    select correct vehicle , select manual scan.
    the Engine module is giving me the following 4 DTC's
    1) P0327
    2) P0332
    3) B0327
    3) P0332

    from the info on reader 1 & 2 relate to knock sensors ? and they clear ok.
    engine light and warning go out but return when i start the engine.

    Could this be related to the fact that the car has been parked for an extended perion ? (Fully charged battery fitted for test)

    DTC's £ & 4 are a bit baffling, they are not in the reader database.
    As far as i am aware the prefix "B" relate to body control module faults, so, why would they appear when interogating the engine module?

    These fault codes DO NOT clear, could this be why the light keeps coming back ?
    Incidently these codes are NOT in the reader database, could ths be a "Typing Error" by the data capturer when they were writing the software?
    And is it possible that they will not clear simply because the reader does not recognise them as engine ECU fault codes ?

    I don't want to go chasing my tail or buying bits that i don't need.

    Another issue i have with the iCarsoft reader is that it will not connect to the Body Control Module, is this normal for this reader ?

    Thank you for any assistance or advice you can offer,

    I have an Ebay purchased copy of !DS 131 ver 6 but i am unsure which VCI to purchase to suit the software, again any advice will be welcome.

    Regards

    Iain

  2. #2
    Super Moderator Ian D's Avatar
    Join Date
    Nov 2008
    Location
    Gosport, Hampshire
    Posts
    5,431
    Post Thanks / Like
    Welcome to the forum.

    Thread moved to the correct section.
    Jaguar XK Coupe 4.2 2006 (2007 MY) in indigo blue, 16 way seats, slate blue/ivory interior, Portfolio mats, 19" Carelia alloys, keyless entry, 2014/15 sat nav DVD update.
    Mods: Power-fold door mirrors, ally weave dash trim, updated chrome stalks, XKR pedals, ACM kit, Speedpack Spoiler, XKR exhaust, late model seat and window switches, Alston Suede roof lining, Upper/Lower Mesh grilles, Redstuff pads all round.
    Resident Super Moderator.
    V6 X-Type Oil Sump Replacement Guide


  3. #3
    Senior Member Lancealot1969's Avatar
    Join Date
    Aug 2016
    Location
    Worksop/Sheffield
    Posts
    172
    Post Thanks / Like
    Hi Iain,

    Welcome to the forum matey, I have had a look on jagrepair and the 327 and332 codes are for your Knock sensors. Voltage out of range poor contact with cylinder head ???
    If I was you I would check the condition of them, if its been stood for a long time ?? I dont know anything about the DTC reader you have mate so I cant help there. Could any contaminants ie oil or coolant have got on them ??? I would take one off at a time clean mating surfaces and try again. Failing that replace each knock sensor but make sure mating surfaces are clean.
    Check your coolant thermostat tower caus if its leaking I dont know if its possible coolant could get to the sensors ??? Theres better members on here that have more knowledge than me who will help.
    Have a look on http://jagrepair.com/JaguarXJ6XJ8Ele...OBDIIcodes.htm may point you in the right direction mate

    All the best

    Lance
    1998 Jaguar XJ8 4L LWB in Jaguar Tudor White, Huggy
    1999 Jaguar XJ8 4L LWB in Jaguar Tudor White, Celeste
    Above all, Have Fun

  4. #4
    Senior Member Andy K's Avatar
    Join Date
    Oct 2008
    Location
    UK
    Posts
    2,251
    Post Thanks / Like
    B code numbers don't go up that high, and very specious they are the same number as the knock codes!

    Very odd you get the same knock errors for both bank. Almost thinking ecu fault!
    They use the same ground as the crank sensor

    The knock and crank sensors go through this connector. Maybe worth a look:
    PI1 57-WAY SUMITOMO TS090 / BLACK ENGINE COMPARTMENT / BULKHEAD / REAR OF ENGINE
    XJR 2001 Pacific Blue

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •