Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: "Battery Not Charging" Message

  1. #1
    Senior Member
    Join Date
    Sep 2016
    Location
    UK, Dorset
    Posts
    115
    Post Thanks / Like

    "Battery Not Charging" Message

    Afternoon all,

    Wondered if anyone has had similar issues with "Battery Not Charging" message appearing. I also noticed, at same time, the cooling fans were going full pelt.

    It does not always happen, once or twice a week at most (for the moment)

    Have done a few short journeys the last couple of weeks so it's due to go on the CTEK at the weekend - I'm hoping this may cure it.



    Thanks
    Alex
    2008 Jaguar XKR 4.2

  2. #2
    Senior Member
    Join Date
    Oct 2012
    Location
    Milton Keynes
    Posts
    6,462
    Post Thanks / Like
    Quote Originally Posted by alex_88 View Post
    Afternoon all,

    Wondered if anyone has had similar issues with "Battery Not Charging" message appearing. I also noticed, at same time, the cooling fans were going full pelt.

    It does not always happen, once or twice a week at most (for the moment)

    Have done a few short journeys the last couple of weeks so it's due to go on the CTEK at the weekend - I'm hoping this may cure it.



    Thanks
    Alex
    I think like you Alex, the battery is possibly your first port of call with most warning lights, especially if the car
    is otherwise performing normally

  3. #3
    Senior Member
    Join Date
    Jul 2007
    Location
    Kent
    Posts
    2,546
    Post Thanks / Like
    I know batteries can be an issue and are an obsession on this site but does a "not charging" light imply issues with the alternator? I have seen the light when the aux belt was flooded in heavy rain and was slipping and also when my alternator packed up.
    1998 XKR Convertible, 2004 S-type V8 SE

  4. #4
    Senior Member
    Join Date
    Sep 2016
    Location
    UK, Dorset
    Posts
    115
    Post Thanks / Like
    I'm wondering that too but it's strange how random it is. I keep meaning to get a multi meter and see if it's actually charging when it says it's not.

    The fans being on full pelt whenever the fault is showing too is also a interesting thing.

    No issues this morning but this evening started it up, within minutes the error came up and fans spun up. Car was stone cold

  5. #5
    Senior Member Shmee's Avatar
    Join Date
    Jun 2015
    Location
    Colchester - Chappel
    Posts
    344
    Post Thanks / Like
    So many things to check!
    Check Fuse 5 RJB, accessory drive belt tension, alternator rotor for slippage etc but could be an ECM fault which I'd suspect with the fans going off, get it read for logged faults. Or get the service/workshop manual and try the pinpoint tests.
    Also check the earth connections in the engine bay (you'll need the manual) and that the battery connections have not loosened.
    2007 XKR Convertible , Zircon Blue, Ivory leather.

  6. #6
    Senior Member
    Join Date
    Sep 2016
    Location
    UK, Dorset
    Posts
    115
    Post Thanks / Like
    I was reading the workshop manual last night on this exact topic, lots to test. I may let Jaguar themselves have a crack - the drive belt is slipping a little as I can hear it squeaking at times. Fans made me wonder if the temp sensor is bad, defaulting them to full blast which in turn could be drawing power away from the battery in a way that'll trigger the not charging message. All specultion of course
    2008 Jaguar XKR 4.2

  7. #7
    Senior Member Shmee's Avatar
    Join Date
    Jun 2015
    Location
    Colchester - Chappel
    Posts
    344
    Post Thanks / Like
    Good luck, but if the belt is slipping remember it also drives the water pump............ which may well explain the fans.
    2007 XKR Convertible , Zircon Blue, Ivory leather.

  8. Likes Ian D liked this post
  9. #8
    Super Moderator Ian D's Avatar
    Join Date
    Nov 2008
    Location
    Hampshire
    Posts
    6,640
    Post Thanks / Like
    Test to see if it is the belt slipping, spray some WD40 on it. Noise goes away, it's the belt, noise stays it's a pulley.

    Roughly £35 for a new belt, but a bit difficult to get to.
    Current Car:
    2017 XE R-Sport 25t 250Ps 18MY.

    Previous Cars:
    2000 S-Type 3.0L SE Auto
    2004 X-Type 3.0L AWD SE Auto estate.
    2007 XK x150 4.2L Coupe

    Resident Super Moderator.
    V6 X-Type Oil Sump Replacement Guide


  10. #9
    Senior Member Shmee's Avatar
    Join Date
    Jun 2015
    Location
    Colchester - Chappel
    Posts
    344
    Post Thanks / Like
    Or the tensioner, having owned an F360 I know the pain.
    2007 XKR Convertible , Zircon Blue, Ivory leather.

  11. #10
    Senior Member
    Join Date
    Sep 2016
    Location
    UK, Dorset
    Posts
    115
    Post Thanks / Like
    Think I'll pop it to Jag for a diagnostic session. Did two 30 mile runs yesterday, no issue then that evening I jumped in to nip to shops and the message re-appeared. Turned engine off and waited for fans to stop, started again and no issues. Very strange
    2008 Jaguar XKR 4.2

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •