Results 1 to 5 of 5

Thread: Electric gremlins getting worse Series 2 4.2C

  1. #1
    Junior Member
    Join Date
    Jun 2016
    Posts
    23
    Post Thanks / Like

    Electric gremlins getting worse Series 2 4.2C

    First it was only the horn and the washer motor. But if i count all gremlins they are far worse. The fuel switch doesn't work, The interior switch doesn't work, The door lights switch doesn't work. The car runs very good on LPG but when i switch to petrol it stops running. I suspect no fuel pump. The clock doesn't tick. Rear windows don't open but the front work fine.
    All the fuses are fine. The car has a key less entrance and a starter button. No key. Can it be that the hobby mechanic who did this forgot to connect a few wires or it is a groundig issue? I can i investigate it the best way. I'm have a multi meter but i'm not really handy using it. All help is welcome.

  2. #2
    Junior Member Shug's Avatar
    Join Date
    Feb 2013
    Location
    Newcastle upon Tyne
    Posts
    25
    Post Thanks / Like
    Hello,

    I'm not an electrician so the specifics of your problem I'll leave to those with better knowledge.

    However, see if you can look at the 2 attachments as it will hopefully show you the wiring diagram for the XJ6C4.2.. I hope it helps.

    http://i1341.photobucket.com/albums/...psyjljxsyj.jpg

    http://i1341.photobucket.com/albums/...ps2umee3qa.jpg


    Jaguar XJ6C 1977 4.2 (carbs) UK RHD ZF4HP

  3. #3
    Junior Member
    Join Date
    Jun 2016
    Posts
    23
    Post Thanks / Like
    Thanks Shug. But i already have a wiring diagram attached to the wall in A3 format. This is a help but doesn't indicate where the trouble is. But, step by step i'm getting there. The biggest cuck-ups i found undtill now are loose connectors that fall af by it self. And those are usually in places behind something, like a dash.

  4. #4
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    7,160
    Post Thanks / Like
    Hi Ron 62. Sounds like you have a big problem on your hands but all can be sussed. I would suggest you get a circuit tester like this http://www.ebay.co.uk/itm/Draper-Hea...gAAOSwxKtYBpke.
    This will enable you to probe for lives or earths. Connect the lead to either earth and probe for live, or connect to a known live and probe for earth.
    It sounds like you have a number of bad connectors or wires.
    Using the multimeter set to Continuity you can probe wires either side of a connector.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 106K Mods:- Electric Autofold Mirrors on Locking , HID Dip Beams
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  5. #5
    Junior Member
    Join Date
    Jun 2016
    Posts
    23
    Post Thanks / Like
    Thanks Roger, I'm already in the proces of checking all the connectors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •