Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Fuel gauge problem on my xj6 4.0 93, american version

  1. #11
    Junior Member
    Join Date
    Jun 2014
    Posts
    15
    Post Thanks / Like
    Dear ALL

    THANK YOU for you precious input. I have followed your advices, and it immediately became clear tht the problem is in the sender unit. I have already ordered one, and this time, I will intall it myself! (First time in a long time I will not pay a mechanic!)

    Meanwhile please dont hesitate to contact me if I can do anything for you in "sunny" Portugal!

    Warm Regards

    Pedro

  2. #12
    Junior Member
    Join Date
    Jun 2014
    Posts
    15
    Post Thanks / Like
    Dear ALL

    THANK YOU for you precious input. I have followed your advices, and it immediately became clear tht the problem is in the sender unit. I have already ordered one, and this time, I will intall it myself! (First time in a long time I will not pay a mechanic!)

    Meanwhile please dont hesitate to contact me if I can do anything for you in "sunny" Portugal!

    Warm Regards

    Pedro

  3. Likes Jimbov8 liked this post
  4. #13
    Senior Member Jimbov8's Avatar
    Join Date
    Apr 2013
    Location
    Worksop
    Posts
    11,232
    Post Thanks / Like
    Glad to help Pedro, hope you get it working soon.
    Jim.
    2009 XK 5.0L PortfolioPast:-87'XJS 3.6L, 93'XJ40 3.2L gold, 95'XJ6 4.0L sport, 00'XJ8 3.2L sport, 2005 XK8 4.2L coupe in that order and enjoyed all of 'em.

    I do not offer advice, I only say what I would do with the set of circumstances presented. Your choice always.

  5. #14
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,392
    Post Thanks / Like
    As Jim says, hope you get it sorted.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 115K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  6. #15
    Junior Member
    Join Date
    Jun 2014
    Posts
    15
    Post Thanks / Like
    Hi ALL!

    THank you for all the suggestions you have graciously sent me. I did buy a new fuel level sender from Barrets, together with seal and lock, and it cost delivered Portugal about 50 Euros....Installed it myself, and it works perfectly! Needle now "rock solid", not "waving" back and forth. ALELUIA!

    I looked closely at the old sender unit, I think it was somewaht "worned out", especially the joint that connects the floater itself to the rest of the piece, and which goes "up and down" and when one refuels and then spends gas....It was somewhat lose, and therefore, the contact with the electrical resistor in the piece was not working properly. I think that this is the "explanation, please excuse me for not being "technical".

    WARM REGARDS To ALL

    Pedro

  7. #16
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,392
    Post Thanks / Like
    Glad you got it sorted, well done.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 115K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  8. #17
    Junior Member
    Join Date
    Jun 2014
    Posts
    15
    Post Thanks / Like
    Thank you, roger!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •