Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Fuel gauge problem on my xj6 4.0 93, american version

  1. #11
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Post Thanks / Like
    Dear ALL

    THANK YOU for you precious input. I have followed your advices, and it immediately became clear tht the problem is in the sender unit. I have already ordered one, and this time, I will intall it myself! (First time in a long time I will not pay a mechanic!)

    Meanwhile please dont hesitate to contact me if I can do anything for you in "sunny" Portugal!

    Warm Regards

    Pedro

  2. #12
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Post Thanks / Like
    Dear ALL

    THANK YOU for you precious input. I have followed your advices, and it immediately became clear tht the problem is in the sender unit. I have already ordered one, and this time, I will intall it myself! (First time in a long time I will not pay a mechanic!)

    Meanwhile please dont hesitate to contact me if I can do anything for you in "sunny" Portugal!

    Warm Regards

    Pedro

  3. Likes Jimbov8 liked this post
  4. #13
    Senior Member Jimbov8's Avatar
    Join Date
    Apr 2013
    Location
    Worksop
    Posts
    11,500
    Post Thanks / Like
    Glad to help Pedro, hope you get it working soon.
    Jim.
    2012 XKR Black pack, Speed Pack, Aero pack, Rat pack. Past:-87'XJS 3.6L, 93'XJ40 3.2L gold, 95'XJ6 4.0L sport, 00'XJ8 3.2L sport, 2005 XK8 4.2L coupe, 2009 XK 5.0L Portfolio in that order and enjoyed all of 'em.

    I do not offer advice, I only say what I would do with the set of circumstances presented. Your choice always.

  5. #14
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    9,051
    Post Thanks / Like
    As Jim says, hope you get it sorted.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 116K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  6. #15
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Post Thanks / Like
    Hi ALL!

    THank you for all the suggestions you have graciously sent me. I did buy a new fuel level sender from Barrets, together with seal and lock, and it cost delivered Portugal about 50 Euros....Installed it myself, and it works perfectly! Needle now "rock solid", not "waving" back and forth. ALELUIA!

    I looked closely at the old sender unit, I think it was somewaht "worned out", especially the joint that connects the floater itself to the rest of the piece, and which goes "up and down" and when one refuels and then spends gas....It was somewhat lose, and therefore, the contact with the electrical resistor in the piece was not working properly. I think that this is the "explanation, please excuse me for not being "technical".

    WARM REGARDS To ALL

    Pedro

  7. #16
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    9,051
    Post Thanks / Like
    Glad you got it sorted, well done.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 116K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  8. #17
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Post Thanks / Like
    Thank you, roger!

  9. #18
    Junior Member
    Join Date
    Nov 2016
    Location
    Long Island New York
    Posts
    17
    Post Thanks / Like
    Hi
    I have a 1991 XJ6 that I bought new. A few years ago the fuel gauge just stopped working and read empty all the time. Turned out to be the sending unit inside the gas tank.
    By the way, two of my closest friends are from Portugal. I’ve visited them several times. Beautiful country.
    Regards,
    Bill

  10. #19
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Post Thanks / Like
    Hi Bill!

    Thank you for your kind reply! The problem is fixed, like you, it was the sending unit inside the tank. Got one for about 50 Euros at Barrets and it's fine!

    Interesting that some of your best friends are from Portugal, and that you have visited several times.

    I am Portuguese-American myself, and when we moved to the USA back in 1974 (Revolution times in Portugal) I lived in Mineola, I believe Cleveland Avenue....I notice you are from Long Island. Went to Hofstra University.

    I actually bought the car from the former Ambassador in Portugal, Gerald McGowan. I knew him well, and I did ride the car when he brought from the States. I loved it. Much later, he called from the US, and asked me if I wanted to buy the car...I did!

    It´s a small world!

    When you come back to Portugal, and need anything, drop me a line on my e-mail: lofotenfish.portugal@sapo.pt

    Warm Regards

    Pedro

  11. #20
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Post Thanks / Like
    Hi Bill!

    Thank you for your kind reply! The problem is fixed, like you, it was the sending unit inside the tank. Got one for about 50 Euros at Barrets and it's fine!

    Interesting that some of your best friends are from Portugal, and that you have visited several times.

    I am Portuguese-American myself, and when we moved to the USA back in 1974 (Revolution times in Portugal) I lived in Mineola, I believe Cleveland Avenue....I notice you are from Long Island. Went to Hofstra University.

    I actually bought the car from the former Ambassador in Portugal, Gerald McGowan. I knew him well, and I did ride the car when he brought from the States. I loved it. Much later, he called from the US, and asked me if I wanted to buy the car...I did!

    It´s a small world!

    When you come back to Portugal, and need anything, drop me a line on my e-mail: lofotenfish.portugal@sapo.pt

    Warm Regards

    Pedro

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •