Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Complex 2.7 XF DSC question

  1. #11
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,940
    Post Thanks / Like
    If you have JLR/SDD it would diagnose the problem.
    What codes are you getting.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 116K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  2. #12
    Junior Member
    Join Date
    Jun 2018
    Location
    London
    Posts
    14
    Post Thanks / Like
    Quote Originally Posted by rchiv View Post
    If you have JLR/SDD it would diagnose the problem.
    What codes are you getting.

    Roger
    Can it be gotten for free from somewhere?

    No DTC’s coming up mate.

  3. #13
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,940
    Post Thanks / Like
    Nothing in this world is completly free. Check this out.
    https://www.jaguarforum.com/showthre...ghlight=Sticky

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 116K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  4. #14
    Junior Member
    Join Date
    Jun 2018
    Location
    London
    Posts
    14
    Post Thanks / Like
    Bit of an update. Still struggling to get it started. Seems to be now that it will start when it wants to, but more often than not, it won’t start. DSC light still on and still getting the restricted performance message.

  5. #15
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,940
    Post Thanks / Like
    What hasn't been covered is was the car starting etc without faults before you stripped it down to drill out the stud. If so then systematically go through everything you did and double check. Sensors will not malfunction just because you have done some work and as long as everything was reconnected correctly you should have no problem.
    Sorry to be a pain but it has to be something along those lines.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 116K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  6. #16
    Junior Member
    Join Date
    Jun 2018
    Location
    London
    Posts
    14
    Post Thanks / Like
    Quote Originally Posted by rchiv View Post
    What hasn't been covered is was the car starting etc without faults before you stripped it down to drill out the stud. If so then systematically go through everything you did and double check. Sensors will not malfunction just because you have done some work and as long as everything was reconnected correctly you should have no problem.
    Sorry to be a pain but it has to be something along those lines.

    Roger
    Funny you mention this. The other day, I found out from the owner that the DSC and restricted performance had come on a few times prior to me stripping it down. He said it would come on, go into limp mode, then would disappear after a shut down and restart. Got an error coming up on the ABS system - U0401-68 which is invalid data received ECM / PCM I.e something powertrain related is not talking to the ECM, but what? The Manual says to check the ECM for DTC’s if this code comes up, but no fault codes are present on the ECM.

    There is a big part of me that still thinks this is battery related. Date on the battery is 2009, and 9 years for a battery is a fair old time (not sure why the battery was replaced after being in the car for only a year initially but anyhow!). Battery was depleted (only had 2v) until we charged it a couple of weeks ago, but in my opinion, once a battery has been depleted to that level, it’s never going to be 100% again. Just to eliminate, I’ve tried clearing the code but it flashes back up instantly soon as the ignition is turned back on.
    Last edited by Peedee; 17-06-18 at 13:02.

  7. #17
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,940
    Post Thanks / Like
    Your on the right lines for the battery. Letting a battery go that low requires a proper revamp which a normal charger will not do.
    The car could be a late 08 which in theory could have an 09 battery. But I would change it anyway.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 116K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  8. #18
    Junior Member
    Join Date
    Jun 2018
    Location
    London
    Posts
    14
    Post Thanks / Like
    Quote Originally Posted by rchiv View Post
    Your on the right lines for the battery. Letting a battery go that low requires a proper revamp which a normal charger will not do.
    The car could be a late 08 which in theory could have an 09 battery. But I would change it anyway.

    Roger
    For sure. I’m slightly hesitant at replacing the battery as there’s always a chance it may not solve the issue, so that’s £xx that would have been wasted. I’d rather 100% know it’s the battery before I go replacing it, otherwise I’m just throwing parts at it hoping it’ll solve the issue. What should these battery’s be at in A1 condition? I’m guessing high 12’s?

  9. #19
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,940
    Post Thanks / Like
    When you have charged the battery, disconnected it should read after 2 hours 12.7v or higher.

    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 116K Mods:- Electric Autofold Mirrors on Locking
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

  10. #20
    Junior Member
    Join Date
    Jun 2018
    Location
    London
    Posts
    14
    Post Thanks / Like
    Quote Originally Posted by rchiv View Post
    When you have charged the battery, disconnected it should read after 2 hours 12.7v or higher.

    Roger
    Cool, I’ll take a check tomorrow. We did charge it up the other day and after an hour it was at 13.1, but clearly that’ll drop a bit after a bit more time. Gonna be stumped if it’s not the battery though

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •