Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Complex 2.7 XF DSC question

  1. #21
    Junior Member
    Join Date
    Jun 2018
    Location
    London
    Posts
    14
    Post Thanks / Like
    So, update on this for anyone following....

    Managed to get back onto the XF today after a few days on other things. Had the battery on a properly good charge, left it for a few hours, checked it.....read 12.7v, ‘happy days’ I thought. Can’t nnected back up, made no difference whatsoever. Still not convinced by this battery, I bit the bullet and bought a new one. Connected it up......bang, car fires up on the button. Tried it a few times, fires up every time, so that’s the starting issue sorted.

    However, a new DTC has decided to flag up, although I’m relatively sure it’s connected to (and is the cause of) the U0401 fault. ‘P0490 - Exhaust has recirculation “A” control circuit high’. Basically means there’s no voltage change to indicate to the the ECU whether or not the EGR is opening / closing, which ‘may’ mean it’s stuck. So, in summary, I think the solenoid in the EGR is faulty, which is causing it to not open and close, which in turn is throwing the UO401 code up and putting it into restricted performance mode as the EGR system will be tied in with the working of the DSC system.

    I took the car for a spin today, and apart from the restricted performance, the car idles and drives perfectly, so I’m happy with that. Will keep you all updated as when things happen!

    On a a different note, if anyone has any experience of either the Autel Maxisys 908, Foxwell GT80 plus or other good diagnostic systems you know of around the 2k mark, I’d be interested to hear your views! Snap on is a no go for me as I’m not in the market for being ripped off because of a name.

  2. #22
    Junior Member
    Join Date
    May 2018
    Location
    UK
    Posts
    23
    Post Thanks / Like
    perhaps you can help me,I am unable to advise on your problem as I am an old school mechanic when you could fix your own car
    2 X turbos and actuators on my 2009 xf 2.7 car is still in limp mode and has been in the garage well two garages now over eight weeks DPF now showing a fault but the first garage has already cleared this as not the fault the Jag garage came up with turbos at first but this has now been proved (hopefully as not the case) I am at my wits end and missing my car nothing against my wifes Fiesta but I think you will get my point .saintphilc@hotmail.com

  3. #23
    Junior Member
    Join Date
    Jun 2018
    Location
    London
    Posts
    14
    Post Thanks / Like
    Well, bit of a strange one to report.

    So, gave the car a final check over on Monday morning (belly panels back on etc) and then the owner took the jaguar to a garage about 15 miles away to have proper diagnostics plugged in to confirm it was the EGR valve. At the point in him picking the car up, the DSC light was on (along with restricted performance) and the CEL was on (EGR fault) but it drove fine. The owner ran into some traffic on the motorway so was just sat there. Then, strangely, the DSC light went out, restricted performance gone and the CEL went out? Car is now back to normal and has been fine since Monday morning? I can only think that where the car has been sat stationary, not had proper use etc for a few months, along with the new battery, perhaps the run out, combined with the heat, has maybe ‘freed’ the solenoid or valve in the EGR or similar? Strange, but in a good way. Time will tell if he has any more issues, but as of now, she’s running 100%.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •