Results 1 to 2 of 2

Thread: ECU broken ? or not...

  1. #1
    Junior Member
    Join Date
    Jun 2018
    Location
    SWEDEN STOCKHOLM
    Posts
    1
    Post Thanks / Like

    ECU broken ? or not...

    Hi , need some urgent help!

    My xj6 3,2 1991 doesent start, the fuel pump relay is not energized on the coil from ECM. Wiring checked.
    Is this defenitely a broken ECM or would it be the same result if crank position sensor is broken?

    Engine cranks
    Fuel pump is running when relay is forced
    No fault codes
    No spark
    Inertia switch ok

    ECM part nr is DBC6472 , if you have one to sell im interested to buy one.

    Best regards/willep

  2. #2
    Senior Member rchiv's Avatar
    Join Date
    Feb 2013
    Location
    Orpington, Kent
    Posts
    8,336
    Post Thanks / Like
    Hi Willep, Welcome to the forum.

    What code reader are you using. If it was an ECU fault then you would have a code of some sort or a failure to read ECM. It looks like a security immobilizer problem rather than an ECU fault.
    As the engine turns over it eliminates the Inertia switch.
    Crank sensor would not stop the fuel pump or spark. But would have a code as well.


    Roger
    HEY I THOUGHT I HAD RETIRED, Ex Auto Electrician
    2006 X Type 2.2d SE Manual Estate. Zurcon Blue Champagne/Mocca, F/R Parking sensors, ,Auto Lights, Auto Wipers, Headlight Washers, Sat Nav 2012 update, 17 in Wheels, 112K Mods:- Electric Autofold Mirrors on Locking , HID Dip Beams
    Simple Autofold Mirrors on Locking,http://www.jaguarforum.com/showthrea...irrors+locking
    UPDATE YOUR SIGNATURE http://www.jaguarforum.com/showthread.php?t=91945

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •