Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: MAF sensor

  1. #1
    Junior Member
    Join Date
    Jul 2018
    Location
    Wolverhampton
    Posts
    10
    Post Thanks / Like

    MAF sensor

    Hi all ,I am new to the forum and new to jaguar ownership .Having read through the forum my 2.0 diesel x type has all the symptoms of a MAF sensor problem but the EML is not showing is this common thanks in advance for any replies

  2. #2
    Senior Member Billy2Jags's Avatar
    Join Date
    Mar 2016
    Location
    Midlands, UK
    Posts
    3,549
    Post Thanks / Like
    What are your symptoms?
    2005 55 reg 06MY 2.0D Sovereign.
    Jaguar Racing Green - HGZ

  3. #3
    Junior Member
    Join Date
    Jul 2018
    Location
    Wolverhampton
    Posts
    10
    Post Thanks / Like
    Hi Billy the car drives fine around town except it sort of occasionally misses a beat but then when i get it on a run and i can go above 50 it feels like intermittent power especially up hill where it is far more noticeable also it lags in acceleration

  4. #4
    Senior Member Billy2Jags's Avatar
    Join Date
    Mar 2016
    Location
    Midlands, UK
    Posts
    3,549
    Post Thanks / Like
    Doesn't sound like maf to me but to prove it either way, just disconnect it and the ecu will default to set parameters.
    If the car drives better it's the maf that is faulty, if no different, start with a new genuine delphi fuel filter and work you way up through a clogged turbo to faulty injectors.
    2005 55 reg 06MY 2.0D Sovereign.
    Jaguar Racing Green - HGZ

  5. #5
    Junior Member
    Join Date
    Jul 2018
    Location
    Wolverhampton
    Posts
    10
    Post Thanks / Like
    Cheers Billy i will try that tomorrow .Thanks for your help

  6. #6
    Junior Member
    Join Date
    Jul 2018
    Location
    Wolverhampton
    Posts
    10
    Post Thanks / Like
    Hi again Billy as i am very inexperienced with any sort of mechanics would i just unplug the MAF filter and take it for a drive and would this have any detriment to the engine sorry if this is a stupid question .

  7. #7
    Junior Member
    Join Date
    Jul 2018
    Location
    Wolverhampton
    Posts
    10
    Post Thanks / Like
    sorry billy i mean MAF sensor

  8. #8
    Senior Member RageMonkey1989's Avatar
    Join Date
    Aug 2016
    Location
    Warrington
    Posts
    1,397
    Post Thanks / Like
    no, it wont cause any damage etc, might be a bit smokey, and it will eventually throw an EML when it realises
    I just saw an Audi driver using his indicators correctly on the motorway. Twice. Should I report the vehicle as stolen?
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    '56 plate X-Type 2.2D Sovereign Winter Gold -- 131k Miles --
    '06 plate X-Type 2.0D Sport Ultraviolet -120k Miles --

  9. #9
    Junior Member
    Join Date
    Jul 2018
    Location
    Wolverhampton
    Posts
    10
    Post Thanks / Like
    will it be just a case of having it plugged in to a diagnostic reader then to erase the eml as there are none showing at the moment . Thanks

  10. #10
    Senior Member RageMonkey1989's Avatar
    Join Date
    Aug 2016
    Location
    Warrington
    Posts
    1,397
    Post Thanks / Like
    Quote Originally Posted by mickf21 View Post
    will it be just a case of having it plugged in to a diagnostic reader then to erase the eml as there are none showing at the moment . Thanks

    when i forgot to plug the MAF back in on the missus 2.0 she drove 25 miles before it came on,

    once plugged back in, if it does come on, it'll clear itself after a couple of days/ restarts.
    I just saw an Audi driver using his indicators correctly on the motorway. Twice. Should I report the vehicle as stolen?
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    '56 plate X-Type 2.2D Sovereign Winter Gold -- 131k Miles --
    '06 plate X-Type 2.0D Sport Ultraviolet -120k Miles --

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •