For info, it does not need 14.2 Telematics software to support TouchPro SOTA (it can be done on earlier versions also)