Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Remote key rubbers

  1. #11
    Senior Member
    Join Date
    May 2017
    Location
    Brackley, UK
    Posts
    672
    Post Thanks / Like
    Quote Originally Posted by Marks_DTM View Post
    Looks to be an XJ specific part......have you considered changing your brand of hand cream to see if that slows the deterioration
    Hand cream, young DTM, are you questioning my sexuality again? Straight Generation X guys do not use handcream.

    This had all the icons rubbed off on purchase, but now the rubber is starting to become detached. I could use a dob of superglue, but if I could get new rubbers first...
    2010 XJ Portfolio running on lorry fuel. I know, Jag Diesel is just wrong!

  2. #12
    Senior Member dbug's Avatar
    Join Date
    Oct 2011
    Location
    Northants
    Posts
    1,142
    Post Thanks / Like
    Always best to use new rubbers TB


    XJ 5.0V8 Portfolio, Mondeo Estate 2.0TDCi, '67 Triumph TR4A

  3. #13
    Senior Member mac_doctor's Avatar
    Join Date
    Oct 2012
    Location
    Gosport
    Posts
    766
    Post Thanks / Like
    I think this thread took a wrong turn somewhere.
    Chris. T.
    2000 XK8 4.0 Coupe
    2010 XJ SWB 3.0D Portfolio. With TVs. Lots of TVs.

  4. #14
    Senior Member
    Join Date
    May 2017
    Location
    Brackley, UK
    Posts
    672
    Post Thanks / Like
    Quote Originally Posted by mac_doctor View Post
    I think this thread took a wrong turn somewhere.
    Its that Marks DTM reprobate...
    2010 XJ Portfolio running on lorry fuel. I know, Jag Diesel is just wrong!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •