Results 1 to 5 of 5

Thread: Detaching the selector lever cable

  1. #1
    Member
    Join Date
    Feb 2018
    Location
    Macclesfield
    Posts
    42
    Post Thanks / Like

    Detaching the selector lever cable

    Anyone know how to detach the gear selector cable? It's at the end of gear stick. Seems to be a round fitment over a ball like spigot. Don't want to break anything.
    My car is stuck in P. Electricals all seem fine. I've got the center console and ash tray assembly out but can't remove the gear selector unit with detaching the cable. Been faffing for 2 hours now, can't figure it out.
    Just want to remove the gear selector unit to inspect and possibly swap out.

    Thanks
    Justin

  2. #2
    Member
    Join Date
    Feb 2018
    Location
    Macclesfield
    Posts
    42
    Post Thanks / Like
    It's ok, sussed it, literally just pops off with a little ply pressure with big screwdriver.
    But next question, there's a pair of wires, (rd/blk) that 'look' like they might go to the shift-lock plunger. Am I correct? I need to test. The shift lock isn't working and I don't know if it's the solenoid itself or the signal to the solenoid.

    Justin
    Last edited by JU55TYN; 07-12-18 at 08:38.

  3. #3
    Senior Member
    Join Date
    Oct 2016
    Location
    Northumberland
    Posts
    982
    Post Thanks / Like
    Quote Originally Posted by JU55TYN View Post
    It's ok, sussed it, literally just pops off with a little ply pressure with big screwdriver.
    But next question, there's a pair of wires, (rd/blk) that 'look' like they might go to the shift-lock plunger. Am I correct? I need to test. The shift lock isn't working and I don't know if it's the solenoid itself or the signal to the solenoid.

    Justin
    you can hear the solenoid operate when it does - and in any event a multimeter would give you the answer to that

    In any case, its probably more likely to be brake lamp related

  4. #4
    Senior Member
    Join Date
    Jan 2016
    Posts
    128
    Post Thanks / Like
    Been there, done that.

    In my case (and many others) it wasn‘t the gear selector cable inside the car but where it connects to the transmission: There are two screws/bolts that tent to come loose.

    It‘s a five minute fix, but you‘ve got to get under the car.

  5. Likes davidcumbria liked this post
  6. #5
    Member
    Join Date
    Feb 2018
    Location
    Macclesfield
    Posts
    42
    Post Thanks / Like
    @ 2woody,
    I'll go a buy an multimeter. The brake lights still work which is why I thought it might be the solenoid itself. Do you know if it is it the pair little red and black wires? The way the selector is assembled you can't actually see exactly where those wires start or end up. If no one knows, I will have to go to the next stage and disassemble the unit and make sure. Oh well, at least it's weekend and I can work in the light.

    @horst1956,
    It's just the selector unit I'm trying to fix. The gearbox is fine, just the solenoid in the gear stick not releasing.
    When I bought the car 10 months ago, I remember thinking that the body, engine and gearbox were good, so what else can go wrong? Apparently the answer is literally everything! Had a tough 10 months with my XJ. Oh well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •