Page 10 of 11 FirstFirst ... 67891011 LastLast
Results 91 to 100 of 107

Thread: Bit the bullet and taxed the S type 4.0

  1. #91
    Senior Member Lost it's Avatar
    Join Date
    Jun 2012
    Location
    Hayling Island
    Posts
    8,422
    Post Thanks / Like
    Well, it's speaker replacement day today. Bought some cheapo things off the interweb because I don't want to spend a fortune then find out the system sounds wooly because, the head unit sounds wooly by default... British designed, made in China. Ah well... Supposed to be a straight swop. Front ones three way, rear ones two way. No idea what the power output of the head unit is, does anyone know? Might make these speakers extremely quiet if it's only 5 watts per channel or something...

    http://fliaudio.co.uk/portfolio/fli-integrator-57/

    http://fliaudio.co.uk/portfolio/fu-57/
    Last edited by Lost it; 05-01-19 at 10:17.
    2001 3.0 SE Auto, Satnav, winter pack. Dark Blue, all the toys.
    2004 3.0 Sovereign Estate. Winter pack. Fixed. For Sale.
    2005 Estate X type 2.2 Sport.
    2000 V8 3.2 XJ8 LWB. "Prom" car. Lovely. Should sell this one too really...
    2005 "AllyCat", 3.0 XJ6 SE.
    2000 S type 4.0 V8. Latest toy.
    VFR800A and a VFR 800F

    Still beating cancer. Trevor 2, Cancer 0.

    Sure I took the Red pill....

  2. #92
    Senior Member
    Join Date
    Apr 2016
    Location
    Near Berlin
    Posts
    3,308
    Post Thanks / Like
    So Trevor which car do you prefer now that you have had the chance to drive the s type for a month now.

    It would be interesting to hear your comparison between your x type and the early s type.
    Grumpy Old Git
    “When a government is dependent upon bankers for money, they and not the leaders of the government control the situation, since the hand that gives is above the hand that takes. Money has no motherland; financiers are without patriotism and without decency; their sole object is gain.”
    Napoléon Bonaparte

    2003 (botox) S type 3.0 sport with manual gearbox, as rare as rocking horse apples

  3. #93
    Senior Member Lost it's Avatar
    Join Date
    Jun 2012
    Location
    Hayling Island
    Posts
    8,422
    Post Thanks / Like
    My XJ trounces both of them... Comfort, speed, stability, fuel consumption, NVH.... I think power to weight it's actually better than the S type.

    The Xype is quicker off the mark up to about 40mph then the V8 gets into it's stride.

    But it knocks them both into a cocked hat aurally.... Nothing beats a V8.

    They are clearly aimed at different markets. The X type is a good every day car, bigger boot than the S type, better heating and ventilation but noisier. The S type is a cruiser, all day comfy.

    The XJ is a wafter. Supremely comfy, very capable. And it won't rot.

    I like all three. And I'm glad I made the decision to buy an S type.
    2001 3.0 SE Auto, Satnav, winter pack. Dark Blue, all the toys.
    2004 3.0 Sovereign Estate. Winter pack. Fixed. For Sale.
    2005 Estate X type 2.2 Sport.
    2000 V8 3.2 XJ8 LWB. "Prom" car. Lovely. Should sell this one too really...
    2005 "AllyCat", 3.0 XJ6 SE.
    2000 S type 4.0 V8. Latest toy.
    VFR800A and a VFR 800F

    Still beating cancer. Trevor 2, Cancer 0.

    Sure I took the Red pill....

  4. Likes ducmon liked this post
  5. #94
    Senior Member Lost it's Avatar
    Join Date
    Jun 2012
    Location
    Hayling Island
    Posts
    8,422
    Post Thanks / Like
    The speaker fit went well, and now I know why two of the windows don't move. Both have been made solid by fixtures. Seems a cable has come adrift on both of them, but I was running out of light, and very chilly after having all four doors in pieces.

    Sound system sounds fantastic with the new speaker units in. The ones I took out look like standard 25 watt Mondeo units.

    Really pleased with it now, plenty of bass, even some clarity.

    But the door interior release handle cups are as fragile as anything, one broke in two... Scrap yard jobby next week.

    So I won't be changing the head unit.
    2001 3.0 SE Auto, Satnav, winter pack. Dark Blue, all the toys.
    2004 3.0 Sovereign Estate. Winter pack. Fixed. For Sale.
    2005 Estate X type 2.2 Sport.
    2000 V8 3.2 XJ8 LWB. "Prom" car. Lovely. Should sell this one too really...
    2005 "AllyCat", 3.0 XJ6 SE.
    2000 S type 4.0 V8. Latest toy.
    VFR800A and a VFR 800F

    Still beating cancer. Trevor 2, Cancer 0.

    Sure I took the Red pill....

  6. #95
    Senior Member
    Join Date
    Nov 2014
    Location
    Norfolk, UK
    Posts
    519
    Post Thanks / Like
    Quote Originally Posted by Lost it View Post
    The speaker fit went well, and now I know why two of the windows don't move. Both have been made solid by fixtures. Seems a cable has come adrift on both of them, but I was running out of light, and very chilly after having all four doors in pieces.

    Apparently not an uncommon problem, indeed it's one of the few things that failed on my old 3.0l. There are plastic guides that the cable hooks into & on mine, the anchor point for one end of the cable broke, letting the cable pull out & tangle & the window drop. Happened to both my rear windows, but never had any problems with the fronts. I guess because the rears had had little use, they became stiff, putting extra load on the cable when they did get used. I found good value comprehensive repair kits from a company called Okzam LTD, they have an ebay store with the appropriate page linked for you here, https://www.ebay.co.uk/sch/m.html?_s...r+kit&_sacat=0

    Regards, OW
    1999 S Type 3.0L SE, A truly lovely old girl that's served me well. Probably the best car I've had. Now retired.
    02.5MY (X202) S Type 2.5L SE, 58,000 miles, full Jag s/h, all papers, MOT's, receipts etc from new when purchased.
    2006 X type SE 2.2 Diesel. Supposed to be Mrs O's economical commuter car.
    2004 (X202) 2.5L Sport plus, to replace the 3.0L

  7. Likes Lost it liked this post
  8. #96
    Senior Member
    Join Date
    Nov 2012
    Location
    Carlisle
    Posts
    1,819
    Post Thanks / Like
    Quote Originally Posted by Lost it View Post
    T
    Sound system sounds fantastic with the new speaker units in. The ones I took out look like standard 25 watt Mondeo units.
    FLI is one of the better UPstarts ( compared to Kenwood, Sony, Pioneer, Panasonic, Etc) not in the league of the High end stuff by any means , but better than a lot of brands that come and dissapear after 5 years..

    The original speakers are probably identical to the Mondeo, probably exactly the same as my 56 Plate Transit too..



    As for the oil...

    I topped mine up last week about 2L in 2,000 miles I recon.

    I should be more careful as the lack of oil in the engine is what seems to have been the demise of the previous engine (without warning) ... The V8 engines seem to quietly consume oil at high rate without showing any real sings. (If it was a turbo I could understand )

    TT
    ================================================== =====================
    Current Cars
    2001 S-Type 4.0 - Pacific Blue
    2002 Galaxy 2.3 Ghia - State Blue
    2002 Galaxy 1.9TDi 130 Zetec - Blue
    2001 S-Type 3.0 Breaker Light Blue
    2004 Renualt Megan RS 225
    1994 Escort 1.6Efi Solar Cabriolet
    1987 Sierra Sapphire 2.3 8v Project - Galaxy Blue
    20?? Haynes Roadster - Black And Zinc Yellow
    2007 Transit 350-100
    Past Jaguars
    2001 S-Type 3.0 Sport - Pacific Blue
    1999 S-Type 3.0 SE - Cardinal Red - Parts Car

  9. #97
    Senior Member Lost it's Avatar
    Join Date
    Jun 2012
    Location
    Hayling Island
    Posts
    8,422
    Post Thanks / Like
    Well that's usefull to know. I thought there was something wrong with the motor...
    2001 3.0 SE Auto, Satnav, winter pack. Dark Blue, all the toys.
    2004 3.0 Sovereign Estate. Winter pack. Fixed. For Sale.
    2005 Estate X type 2.2 Sport.
    2000 V8 3.2 XJ8 LWB. "Prom" car. Lovely. Should sell this one too really...
    2005 "AllyCat", 3.0 XJ6 SE.
    2000 S type 4.0 V8. Latest toy.
    VFR800A and a VFR 800F

    Still beating cancer. Trevor 2, Cancer 0.

    Sure I took the Red pill....

  10. #98
    Senior Member Lost it's Avatar
    Join Date
    Jun 2012
    Location
    Hayling Island
    Posts
    8,422
    Post Thanks / Like
    Well. That didn't go too well...

    When I "tested" the sound system I used MJ's "Billy Jean" for the bass test, and a bit of Bach for the rest of the trial, some of his Organ stuff is very good at highlighting problems, and of course the intro to "War of the Worlds" with Richard Burton's narration for voice.

    And it sounded presentable, but I was doing it on the drive.

    I went to Peterborough in the car last week, and as I had set the volume for a stationary car with engine running it was fine.
    Right until the AVC started to boost the volume as the car went a little faster. I have it set on level 2 AVC. As the car got quicker and the AVC did it's bit, the sound got steadily out of kilter, the Bass left the car first, then the noise started to get really unpleasant. My daughter described it as "It's like it's turning any bass off as soon as you get to 60mph..."

    I can only describe it as severe clipping. And that will soon ruin the speakers. So I'm back at square 1. I have reset the AVC at level 1, and still it loses control really quickly, I guess I was hoping for too much. I still have no idea what the actual power output is on the head unit, it's not much...

    So I started looking yesterday, for a "Premium sound" set up for the S type, and whereas I can find the door speakers the head unit isn't as available. So what to do?

    It seems people want silly money for the 2nd hand speakers that I would be purchasing if I bought off 'bay, and no-one seemed to have the rear parcel shelf bit anyway.

    Are my options limited now to changing the head unit, or getting something that can "boost" the sound as it comes from the head unit, allowing me to retain the unit but only use low volume on the control?
    Well it's beyond me, so I went to see Cannon Audio in Waterlooville, let him listen to it after explaining what the problem seems to be, and he more or less said that the speakers I have put in are better than basic fitment but only just. The head unit is basic "Ford" and won't be good quality, and between them there's not much that can be done if I wish to retain the original head unit. So the options are an active sub unit in the boot to take the "responsibility" for the bass out of the hands of the head unit, and some more sensitive speakers. Or change the head unit.

    Just so happens I have a "spare" Sony unit that I took out of my wife's old Renault, and I think I have the adapter cables too, so I'm going to do a quick swop today, if that fails then I will need to change the speakers to something a bit more able to handle the kind of stuff I want to hear. It's a shame, but I don't see any options, I'm using the car for three hours a time and I need to be able to listen to what I want without it being a distraction.

    And... The offside rear door lock has now frozen too. So that's the window winder mechanism and the lock I need to sort out. Guess the relay went the same way as the other side?
    Last edited by Lost it; 17-03-19 at 06:50.
    2001 3.0 SE Auto, Satnav, winter pack. Dark Blue, all the toys.
    2004 3.0 Sovereign Estate. Winter pack. Fixed. For Sale.
    2005 Estate X type 2.2 Sport.
    2000 V8 3.2 XJ8 LWB. "Prom" car. Lovely. Should sell this one too really...
    2005 "AllyCat", 3.0 XJ6 SE.
    2000 S type 4.0 V8. Latest toy.
    VFR800A and a VFR 800F

    Still beating cancer. Trevor 2, Cancer 0.

    Sure I took the Red pill....

  11. #99
    Senior Member Neilr's Avatar
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    4,262
    Post Thanks / Like
    Sounds strange, if you excuse the pun. The standard head unit with decent speakers should sound OK. Maybe the head unit is is faulty or the speakers particularly poor.

    The Premium Sound speakers were also not very good sounding even when they were new. I replaced mine right at the start with Infinity ones and that was a massive improvement. More recently, I replaced those with Focal ISS 570s at the front and ISC 570s at the back. They are clearer and much more natural sounding. The bass is handled by the original sub and the overall sound is not at all bad.

    The head unit is this one: https://www.ebay.co.uk/itm/JAGUAR-S-...frcectupt=true and they are common on US Ebay.

    A few years back, I fitted the Fiat Coupe with a modern Pioneer head unit, decent but not overly expensive component speakers and a small Pioneer sub. It also sounds fine, especially as the bass is handled by the sub and the head unit has a lot less to do. Getting reasonable sound quality and level should not be too hard as long as the source is good (CD or HQ MP3, etc).
    S-Type 3.0 Manual MY2001 in Pacific Blue with Cashmere Leather Sport Seats, Sunroof, Melbourne Alloys, Premium Sound plus some other stuff ... 55k miles.
    XKR 5.0 Speed Pack MY2011 in Polaris White with Ivory/Charcoal Leather, Nevis Alloys and R-Performance Interior plus some other stuff ... 17k miles.
    Hyundai Tucson 1.6T AWD MY2016 in White Sand. Basic, comfortable and surprisingly fast and competent ... 12k miles.
    FIAT Coupe MY1997 in Steel Grey with Tan Leather ... 55k miles.

  12. #100
    Senior Member Lost it's Avatar
    Join Date
    Jun 2012
    Location
    Hayling Island
    Posts
    8,422
    Post Thanks / Like
    Well, I changed the front speakers and discovered that the polarity was different on the Sony unit? As in the negative on one side was now positive... Which was a little strange.

    But cosmetically it looks horrible. And it's a proper pig to do, there's hardly any give in the wiring loom, the heated seat switches didn't want to unlatch, the wiring loom conversion was way too bulky and I now have a space under the unit. Which I have lined with some thin rubber for now and I will use it as "somewhere" to put the Ipod. Managed to retain the coin tray and the mobile phone set up, but a proper pig to do. I think I might be able to get a "double din" unit in there if I try hard enough.

    So I'll keep the old unit ready to transfer it back when I'm ready. Definitely doesn't need the "sub" in the boot now. The Sony head unit with it's supposedly 50 watts per channel is more than capable. I also managed to retain the steering wheel volume conrol, and the source button turns it off, but that's about all I have. And as the Sony unit also has a CD built in, it's pretty much done all I needed.

    So I'm on the look out for a normal glove box so that I can remove the CD unit from in the glove box. Get some space back.

    But it doesn't look very nice.
    2001 3.0 SE Auto, Satnav, winter pack. Dark Blue, all the toys.
    2004 3.0 Sovereign Estate. Winter pack. Fixed. For Sale.
    2005 Estate X type 2.2 Sport.
    2000 V8 3.2 XJ8 LWB. "Prom" car. Lovely. Should sell this one too really...
    2005 "AllyCat", 3.0 XJ6 SE.
    2000 S type 4.0 V8. Latest toy.
    VFR800A and a VFR 800F

    Still beating cancer. Trevor 2, Cancer 0.

    Sure I took the Red pill....

Page 10 of 11 FirstFirst ... 67891011 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •