Results 1 to 5 of 5

Thread: Speakers Crackling

  1. #1
    Junior Member
    Join Date
    Oct 2018
    Location
    Cumbria, England UK
    Posts
    22
    Post Thanks / Like

    Speakers Crackling

    Hi, Premium Sound System Faulty, turn on audio system and sub woofers making a loud crackling noise & front and rear speakers low volume/poor quality, my first thoughts are the amplifier in the boot is faulty, just wondering if anyone else had this problem, only other thing it could be is optical cables. also same fault using jaguar voice.

    Many thanks

    Chris.

  2. #2
    Senior Member Jim_S-V6_2004's Avatar
    Join Date
    Jun 2013
    Posts
    17,162
    Post Thanks / Like
    Most likely an earthing problem Chris.

    .

  3. Thanks Chris45uk thanked for this post
    Likes Chris45uk liked this post
  4. #3
    Junior Member
    Join Date
    Oct 2018
    Location
    Cumbria, England UK
    Posts
    22
    Post Thanks / Like
    Problem Solved, stripped amplifier in boot, found serious corrosion to circuit board, fitted 2nd hand amp, all fine now.

  5. #4
    Senior Member Jim_S-V6_2004's Avatar
    Join Date
    Jun 2013
    Posts
    17,162
    Post Thanks / Like
    Oh, that's a surprise Chris.

    Rainwater getting in from the boot lid seal?

  6. Thanks Chris45uk thanked for this post
  7. #5
    Junior Member
    Join Date
    Oct 2018
    Location
    Cumbria, England UK
    Posts
    22
    Post Thanks / Like
    Seems nice and dry in the boot, I upgraded the System to Premium Sound as the car didn't have it originally, bought the amp off ebay, may have been sitting in a car with the boot open in a scrapyard is my theory.

  8. Likes S-Type Owner liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •