Results 1 to 3 of 3

Thread: P01010A MAF Error

  1. #1
    Senior Member
    Join Date
    Feb 2007
    Location
    Wales, UK
    Posts
    759
    Post Thanks / Like

    P01010A MAF Error

    HI All. I have this P01010 code coming up with monotonous regularity on my 2003 4.2 XJ8, relating to the MAF reading being out of range. I've checked the inlet for leaks and cannot see any, and I've cleaned the MAF with the correct cleaner. The garage said that it put the light on before I bought it and he swapped a "known good" MAF from another car into it. My freeze frame data is

    Vehicle Speed: 36mph
    Engine Speed: 1578rpm
    Throttle Position: 10%
    MAF air flow rate: 14.83g/sec
    Intake MAP: 39kPa
    Fuel Pressure: 387kPa
    Short term fuel trim bank 1: -2.34375%
    Long term fuel trim bank 1: -2.34375% (suspiciously similar)
    Short term fuel % trim bank 2: -0.78125%
    Long term fuel trim bank 2: -3.125%
    Engine coolant temp: 89C
    Timing advance 42 degrees
    e
    Which all looks perfectly sane to me, I'd expect about 14.83g a sec air flow with those parameters. Fuel trims don't suggest an air leak either, if I'm understanding them correctly? Does anyone have any bright ideas?!

  2. #2
    Senior Member
    Join Date
    Oct 2016
    Location
    Northumberland
    Posts
    1,112
    Post Thanks / Like
    it looks like you have a "known good MAF" from another car, which looks the same and fits in the same hole, but is in fact different.

    the part numbers MUST be the same - there are lots that will look identical, but aren't

    don't ask me how I know this.......

  3. #3
    Senior Member
    Join Date
    Feb 2007
    Location
    Wales, UK
    Posts
    759
    Post Thanks / Like
    Would that make the EML only illuminate occasionally?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •