Page 4 of 4 FirstFirst 1234
Results 31 to 34 of 34

Thread: engine feels like its "holding back"

  1. #31
    Senior Member Jag-Black's Avatar
    Join Date
    Aug 2016
    Location
    Cambridgeshire UK.
    Posts
    2,291
    Post Thanks / Like
    Oh ok. Injectors too complicated for me.

    Cool. Hope you get a good result without too much fuss.

    That's why I didn't try Redex til last. I was told it would make my moped go faster when I was a kid, and it didn't. It did make an impressive white cloud for miles worthy of the Red Devils.
    2006 Black Jaguar X400 | 6 Speed Manual Transaxle - MMT6 | Series 60 | 2.2L Duratorq 16V TC (150PS) - Puma | 4 Door Saloon

  2. Thanks rob78 thanked for this post
    Likes RWD3M liked this post
  3. #32
    Senior Member rob78's Avatar
    Join Date
    Jan 2019
    Location
    Lincoln
    Posts
    332
    Post Thanks / Like
    full of zx1 and redex advanced now, tried to stay away from the car for a week as its doing my head in, noticed injector number one making a ticking noise on acceleration so armed with new seals, washers, injectors, mongoose and a big hammer I will attempt to sort the damned thing once and for all this wkend.
    2006 X Type 2.2D Sport 108k

    Alex!.....get off the cat.

  4. Likes Jag-Black liked this post
  5. #33
    Senior Member rob78's Avatar
    Join Date
    Jan 2019
    Location
    Lincoln
    Posts
    332
    Post Thanks / Like
    well, i doth my cap to you mr jag-black sir.

    your redex advanced and zx1 concoction has sorted it

    50ml zx1 in tank when it was just above red line, around 20 miles then fill up with Jet diesel and a bottle of redex advanced, 1/4 of a tank gone and so has the shaking / juddering, can hold it at 60 in 5th now and it doesnt miss a beat, shoved the other 200ml of zx1 into the oil filler and i have a quieter engine to boot now too.

    I honestly thought it was going to need new injectors and coding, just spent a shedload of cash to do the job this weekend now ive got to try and send it all back lol

    never again will I bag off redex, I swear my 0-60 time has been halved and my exhaust fumes smell pine fresh too!
    Last edited by rob78; 22-02-19 at 17:00.
    2006 X Type 2.2D Sport 108k

    Alex!.....get off the cat.

  6. Likes RF900R, Jag-Black liked this post
  7. #34
    Senior Member Jag-Black's Avatar
    Join Date
    Aug 2016
    Location
    Cambridgeshire UK.
    Posts
    2,291
    Post Thanks / Like
    Well Mr rob78 sir, I tip my hat to you too for giving it a go in the absence any scientific evidence whatsoever.

    I'm really pleased it worked for you, not only to have your motor back, but also because that makes it less of a coincidence.

    A bit of ZX1 in the steering was a good move on mine, taken a sludgy feel at centre away and started responding better instead.

    After 12 years and +180K miles, it's not surprising a bit of extra metal lube does them good.

    Really pleased it improved yours too. Happy days.

Page 4 of 4 FirstFirst 1234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •