Results 1 to 2 of 2

Thread: Horn issue

  1. #1
    Junior Member
    Join Date
    May 2018
    Location
    USA, Utah
    Posts
    5
    Post Thanks / Like

    Horn issue

    So, I picked up my 1987 Jag XJ6 from a previous owner who had installed a "horn button" to bypass the steering column. Essentially connecting the purple/black to one terminal on the button and black ground to the other. I am attempting to take back to the original wiring/system. When I do connect the purple/black to the lower, steering terminal and the black to the upper column terminal, it sounds and won't stop. So, I replaced the relay. Same issue. Then, I moved the steering wheel (turn/telescope) and it goes on, off, on, off etc as if there is something grounding the steering column. I have removed the steering pad and even the brass rod and it still sounds. Interested in any theories to attempt to repair. Thanks so much in advance!

  2. #2
    Senior Member
    Join Date
    Apr 2017
    Location
    Latvia
    Posts
    116
    Post Thanks / Like
    in your case the steering column has to be removed.
    There are insulation bushes inside that are shorting the center pin to ground and thus activating the horn nonstop.
    The relay in the engine compartment gets +12V continuous when ignition is ON, but gets the ground (-) from the steering column.
    good luck & keep us posted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •