Results 1 to 9 of 9

Thread: Retrofit fail

  1. #1
    Junior Member
    Join Date
    Jul 2018
    Posts
    6
    Post Thanks / Like

    Retrofit fail

    Hi, I've been attempting to retrofit a touchscreen satnav into my 2003 X type SE. Two months have passed, and I think it's time to give up?
    I've scoured this forum and Internet in detail for ideas and instructions but I keep getting new problems.
    The unit is installed, I've spliced all of the wires into the correct places (I think), and got the two pairs of SCP wires sorted.
    I have a d2b cable in the boot linking the cdc, nav, phone and voice modules; but have two spare plugs- I can't find an amp one, as the car doesn't have premium sound, and the other one I am at a loss to explain.
    Any suggestions?

  2. #2
    Senior Member
    Join Date
    Dec 2013
    Location
    Berkshire
    Posts
    2,321
    Post Thanks / Like
    Are you saying the D2B optical link has two spare plugs ?

    If so remove them, there should be a howto somewhere on this site or you may be able to find it via Google.

    The second spare plug could be for the XJ rear sound system
    S Type 4.2 SE Plus 2002 original spec: Xenon HID/SatNav/Voice/Cassette Player/CDC/TV/GSM Phone/Sun Roof/Rear Blind/CATS.
    Retro-fitted: CD Player/Bluetooth Phone/Aux Power Socket, USB & Volt Meter in Boot/Reversing Cam/Dash Cam & PSU/Dual USB sockets in Armrest/
    Wireless Phone Charger under Instrument Surround.
    Pictures of technical stuff

  3. #3
    Junior Member
    Join Date
    Jul 2018
    Posts
    6
    Post Thanks / Like
    Hi, yes- there's one for an amp (I don't believe I have one), and another for something unknown.
    I've connected the existing one in the boot to the cdc. The nav, voice and phone modules are separate.

    Do you reckon I should connect the existing boot plug to the nav, cdc, voice and phone directly? I have the correct Order somewhere.
    Thanks

  4. #4
    Senior Member jagryan85's Avatar
    Join Date
    Feb 2012
    Location
    Wirral|England|UK
    Posts
    3,453
    Post Thanks / Like
    Have you fitted the remote climate control module (rccm) in place of the old climate control unit?
    "One shall not fix something if something need not to be fixed"
    2005 4.2 V8 S-Type Executive - Sat Nav with Reverse Camera, DVD, Winter Pack - Auto HID's & Wipers, Headlamp Washers & Heated Seats. F&R Parking Aid, Power Folding Mirrors, Mesh Grille, Memory Seats, 18" Mercury's, Towbar, Privacy Shades, Parrot MKi9200, Dash Cam.
    Previous: 01 X-Type 2.1 SE, 01 X-Type 2.5 SE, 02 X-Type 3.0 Sport
    Summer Toy - 2007 Triumph Sprint ST 1050 in Caspian Blue

  5. #5
    Senior Member
    Join Date
    Dec 2013
    Location
    Berkshire
    Posts
    2,321
    Post Thanks / Like
    Yes you need to connect it to all devices that you have in the correct order as you say, but the extra plugs and optical links must be removed as it operates as a serial link.

    The cdc and all other modules you have MUST be connected via a single D2B link plugged into the car loom connector.

    I.e. If one plug is not connected nothing will work as the link is broken, hence the need to remove the extra ones.

    It is not difficult to do.
    S Type 4.2 SE Plus 2002 original spec: Xenon HID/SatNav/Voice/Cassette Player/CDC/TV/GSM Phone/Sun Roof/Rear Blind/CATS.
    Retro-fitted: CD Player/Bluetooth Phone/Aux Power Socket, USB & Volt Meter in Boot/Reversing Cam/Dash Cam & PSU/Dual USB sockets in Armrest/
    Wireless Phone Charger under Instrument Surround.
    Pictures of technical stuff

  6. #6
    Junior Member
    Join Date
    Jul 2018
    Posts
    6
    Post Thanks / Like
    Yes, I mounted it to the left of the clutch, and connected the black and white connectors from the old digital unit.

  7. #7
    Senior Member x_type_lpg's Avatar
    Join Date
    Sep 2012
    Location
    Frinton on Sea
    Posts
    780
    Post Thanks / Like
    Quote Originally Posted by AsX-type View Post
    Yes, I mounted it to the left of the clutch, and connected the black and white connectors from the old digital unit.
    where are you located? if you want a drive to frinton on sea I can sort it 4 u

  8. #8
    Senior Member Spudgun!'s Avatar
    Join Date
    Oct 2017
    Location
    Devon
    Posts
    244
    Post Thanks / Like
    I'm of the impression that your D2B cable has more plugs than you have modules. The D2B cable can be dismantled to take out the bits you don't need (I've done this myself). The D2B loop must be complete, or nothing will work correctly.
    2002 2.1SE.
    Retro fitted CD changer, GSM phone, Voice Control and Sat Nav.

  9. #9
    Junior Member
    Join Date
    Nov 2018
    Location
    Cyprus / Larnaca
    Posts
    24
    Post Thanks / Like

    new loom

    I have just completed the same job on the identical model & year. The problems as you say just keep coming. I took the view in the
    end to opt for a plug and play direct satnav loom from boot to head unit thus bypassing the scp problem and the need for the small extension loom
    from the satnav loom (green plug) under the glove compartment. I even installed the odroid computer system.
    The person I can recommend to supply you with the complete loom is Steve Robinson email address stevenrbnsns@aol.com he is excellent.
    Incidentally I also did not fit the PSE or BTUM units but purchased the newer Blue tooth module - see attached photo.

    https://www.ebay.co.uk/itm/Jaguar-X-...rk:13:razz:f:0

    regards

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •