Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: X-Type rear parking sensors not working.

  1. #11
    Senior Member rob78's Avatar
    Join Date
    Jan 2019
    Location
    Lincoln
    Posts
    158
    Post Thanks / Like
    Yeah outer ones are straight, squirt of wd40 and undo top and bottm clip and they pull out towards you if you are under the car.
    2006 X Type 2.2D Sport (90% right, WIP)
    2005 Mitsubishi Colt Mirage (just been hit by a deer)

    Fixing stupid since 2016

  2. #12
    Junior Member
    Join Date
    Mar 2008
    Location
    Four Marks, ALTON, Hampshire
    Posts
    8
    Post Thanks / Like

    Smile

    The new sensor arrived this afternoon. £6.48 from eBay, listed as a Landrover Discovery part YDB500301PMA.

    With the benefit of having previously taken the duff sensor out and swapped it with the near side working one (in order to eliminate any wiring fault) and then swapped it back again, it was a 5 minute job to install the new one. So it's goodbye to that annoying 5 second beep on startup and I can now look forward to bump free parking once again! 😏

    Because the whole assembly is black it was originally difficult to know which bits of plastic belonged to the connector, which bits belonged to the sensor and which bits belonged to the housing. Understanding the exact relationship between the various parts was key to getting the job done without damaging anything.
    JAGUAR X-TYPE 2004-2010 Diesel 2.0L Manual 5 doors SE DCI Estate

    2004 registered 145,000 miles

  3. #13
    Senior Member Faltwen's Avatar
    Join Date
    Sep 2011
    Location
    Sunny Scunny
    Posts
    582
    Post Thanks / Like
    That's good news and not too expensive.

  4. #14
    Senior Member
    Join Date
    Feb 2019
    Posts
    128
    Post Thanks / Like
    Don't understand why people don't replace it with an aftermarket system. Its a complete new system and better. If the factory system display parking diagram on the display then i can understand this.

  5. #15
    Senior Member Faltwen's Avatar
    Join Date
    Sep 2011
    Location
    Sunny Scunny
    Posts
    582
    Post Thanks / Like
    Are aftermarket sensors the same size as original ones because IIRC the set I fitted to my previous Mondeo had smaller sensors and they'd rattle about in the hole's on the X Type.
    Now - 2016 Jaguar XE Prestige 2.0 petrol in Bluefire - Parking Assist Pack, heated screen.
    Had - 2008 - 2.2 Auto Sovereign Saloon - Genuine Sovereign Glacier Blue with heated screen, piped seats, Satnav, Premium Sound System, Jaguar Voice, Front and Rear Sensors, Walnut Steering Wheel and dash, Proteus 18" Wheels plus the dreaded DPF!!!!
    2003 2.5L SE - Ultraviolet.

  6. #16
    Senior Member
    Join Date
    Feb 2019
    Posts
    128
    Post Thanks / Like
    Quote Originally Posted by Faltwen View Post
    Are aftermarket sensors the same size as original ones because IIRC the set I fitted to my previous Mondeo had smaller sensors and they'd rattle about in the hole's on the X Type.
    Not sure I would thought they be similar size. If slightly smaller just seal the inside to stop rattle.

  7. #17
    Senior Member Faltwen's Avatar
    Join Date
    Sep 2011
    Location
    Sunny Scunny
    Posts
    582
    Post Thanks / Like
    In my opinion. It must be a lot simpler to fit an original sensor at £6.48 then to fit a set that actually doesn't fit in the original holes and if not held correctly could cause more issues then not having them and I have completed both jobs on previous cars.
    Now - 2016 Jaguar XE Prestige 2.0 petrol in Bluefire - Parking Assist Pack, heated screen.
    Had - 2008 - 2.2 Auto Sovereign Saloon - Genuine Sovereign Glacier Blue with heated screen, piped seats, Satnav, Premium Sound System, Jaguar Voice, Front and Rear Sensors, Walnut Steering Wheel and dash, Proteus 18" Wheels plus the dreaded DPF!!!!
    2003 2.5L SE - Ultraviolet.

  8. #18
    Senior Member
    Join Date
    Feb 2019
    Posts
    128
    Post Thanks / Like
    Quote Originally Posted by Faltwen View Post
    In my opinion. It must be a lot simpler to fit an original sensor at £6.48 then to fit a set that actually doesn't fit in the original holes and if not held correctly could cause more issues then not having them and I have completed both jobs on previous cars.
    The size on the aftermarket sensors is 21mm. 21mm is hole size. What size is the factory ones?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •