Results 1 to 7 of 7

Thread: Maff?

  1. #1
    Senior Member
    Join Date
    Aug 2013
    Posts
    756
    Post Thanks / Like

    Maff?

    One of my panzer wagons will only run for about 10seconds is this a typical symptom of a faulty maff?

  2. #2
    Senior Member Jimbov8's Avatar
    Join Date
    Apr 2013
    Location
    Worksop
    Posts
    12,392
    Post Thanks / Like
    Quote Originally Posted by s collins View Post
    One of my panzer wagons will only run for about 10seconds is this a typical symptom of a faulty maff?
    Good god Alfie, what is this sorcery you speak of. Have you and Clarkey been breeding more floozies.

    Fuel pump, fuel filter and MAF. Any codes or faults being flagged up?
    Jim.
    2012 XKR Black pack, Speed Pack, Aero pack, Rat pack. Past:-87'XJS 3.6L, 93'XJ40 3.2L gold, 95'XJ6 4.0L sport, 00'XJ8 3.2L sport, 2005 XK8 4.2L coupe, 2009 XK 5.0L Portfolio in that order and enjoyed all of 'em.

    I do not offer advice, I only say what I would do with the set of circumstances presented. Your choice always.

  3. #3
    Senior Member
    Join Date
    Aug 2013
    Posts
    756
    Post Thanks / Like
    Haven’t had it on a machine yet as I can’t get it to the garage , I’ve got some brake cleaner and was thinking about giving it blast ?
    its only got 60k and I’m thinking more that it’s lack of use more than anything else.

  4. #4
    Senior Member FastEddie's Avatar
    Join Date
    Apr 2017
    Location
    Milton Keynes
    Posts
    1,875
    Post Thanks / Like
    Quote Originally Posted by s collins View Post
    One of my panzer wagons will only run for about 10seconds is this a typical symptom of a faulty maff?
    Sturmpanzerwagen Oberschlesien having troubles eh ! Sounds fuel related. Does it die if you rev it as soon as it starts as well ? Faulty MAF would kill it at idle speed but not normally with some gas on. If problem is only at idle, may be the ICV stuck shut, this normally opens on start up and settles to fast idle until warmed up and then down a little lower. May be worth a strip and clean out.

    2009 , X358 LWB , 2.7 TtcrdiV6 , Liquid Silver



  5. Thanks s collins thanked for this post
    Likes Jimbov8 liked this post
  6. #5
    Senior Member
    Join Date
    Aug 2013
    Posts
    756
    Post Thanks / Like
    Eddie it fires up won’t rev and just dies,

  7. #6
    Senior Member FastEddie's Avatar
    Join Date
    Apr 2017
    Location
    Milton Keynes
    Posts
    1,875
    Post Thanks / Like
    Quote Originally Posted by s collins View Post
    Eddie it fires up won’t rev and just dies,
    Try unplugging the MAF sensor in the air duct and see if it starts and runs.

    If it does and is running rough then it is the MAF, a delicate clean of the wire with thinners / carb cleaner may resolve.
    2009 , X358 LWB , 2.7 TtcrdiV6 , Liquid Silver



  8. Thanks s collins thanked for this post
  9. #7
    Senior Member
    Join Date
    Aug 2013
    Posts
    756
    Post Thanks / Like
    Thankyou everyone that contributed towards this query ��
    anyone got a maff for sale ��

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •