Page 15 of 15 FirstFirst ... 51112131415
Results 141 to 150 of 150

Thread: Steve's XJ V8 Portfolio Thread.

  1. #141
    Senior Member mac_doctor's Avatar
    Join Date
    Oct 2012
    Location
    Gosport
    Posts
    1,746
    Post Thanks / Like
    Quote Originally Posted by #steve View Post
    Mine doesn't look like yours:



    ... but it still has the blue cap on the windscreen washer bottle (the only bit I recognise)

  2. Thanks #steve thanked for this post
    Likes #steve liked this post
  3. #142
    Senior Member
    Join Date
    May 2017
    Location
    Brackley, UK
    Posts
    1,244
    Post Thanks / Like
    Quote Originally Posted by mac_doctor View Post
    Mine doesn't look like yours:



    ... but it still has the blue cap on the windscreen washer bottle (the only bit I recognise)
    Yours, like mine, is an earlier, less powerful variant, with just one air filter.

    Later 300bhp ones had twin air filters, making the front of the engine look quite different.
    2010 XJ Portfolio running on lorry fuel. I know, Jag Diesel is just wrong!

  4. Thanks #steve thanked for this post
    Likes #steve liked this post
  5. #143
    Senior Member #steve's Avatar
    Join Date
    Feb 2017
    Location
    Middlesbrough
    Posts
    802
    Post Thanks / Like
    Chris, the yellow cap is the power steering and the one with red on is for the engine oil lol.
    2010 Jaguar XJ V8 Portfolio.

  6. Likes Ashanti liked this post
  7. #144
    Senior Member mac_doctor's Avatar
    Join Date
    Oct 2012
    Location
    Gosport
    Posts
    1,746
    Post Thanks / Like
    Quote Originally Posted by #steve View Post
    Chris, the yellow cap is the power steering and the one with red on is for the engine oil lol.
    Thanks for that, but they are two things that I definitely won't be using! The nearest I get to engine oil is when I fill it with diesel.

  8. Thanks #steve thanked for this post
    Likes #steve liked this post
  9. #145
    Senior Member #steve's Avatar
    Join Date
    Feb 2017
    Location
    Middlesbrough
    Posts
    802
    Post Thanks / Like
    Quote Originally Posted by mac_doctor View Post
    Thanks for that, but they are two things that I definitely won't be using! The nearest I get to engine oil is when I fill it with diesel.
    Well there's a surprise lol

    Today I thought I would check the earth studs as they are a known problem on the X350/8.

    As you can see from the photo they look like they have been improved. So I just gave them a good clean and sprayed them with WD40.





    Before and after shots.
    2010 Jaguar XJ V8 Portfolio.

  10. Likes coling, Ashanti liked this post
  11. #146
    Senior Member #steve's Avatar
    Join Date
    Feb 2017
    Location
    Middlesbrough
    Posts
    802
    Post Thanks / Like
    This week I have been dealing with the rear subframe. As the car spent most of its life in Perth shire, there was a lot of surface rust to get rid of.

    After the surface rust was removed a coat of Kurust was applied. After letting it dry, the next day a I coated the subframe in clear Waxoyl.

    picupload

    Hopefully this should help for the winter. The front subframe didn't need any work.
    2010 Jaguar XJ V8 Portfolio.

  12. Likes mac_doctor, Ashanti liked this post
  13. #147
    Senior Member mac_doctor's Avatar
    Join Date
    Oct 2012
    Location
    Gosport
    Posts
    1,746
    Post Thanks / Like
    Quote Originally Posted by #steve View Post

    Lovely. I don't know where on the car that is, but it is splendid. Good job.

    Actually, now I look a bit closer, I think I do know where that is: I think I have a similar picture somewhere. Don't go away:

    *Rummage, rummage*

    Aha!

    Last edited by mac_doctor; Yesterday at 09:19.

  14. Thanks #steve thanked for this post
    Likes WanderingTeacake, #steve, Ashanti liked this post
  15. #148
    Senior Member #steve's Avatar
    Join Date
    Feb 2017
    Location
    Middlesbrough
    Posts
    802
    Post Thanks / Like
    Thanks Chris, yes your photo is the same area.

    It looks like your subframe has mild surface rust.
    2010 Jaguar XJ V8 Portfolio.

  16. Likes mac_doctor liked this post
  17. #149
    Senior Member mac_doctor's Avatar
    Join Date
    Oct 2012
    Location
    Gosport
    Posts
    1,746
    Post Thanks / Like
    Quote Originally Posted by #steve View Post
    Thanks Chris, yes your photo is the same area.

    It looks like your subframe has mild surface rust.
    Only mild? Good - I can live with that. More of the problem is that stick-y thing waggles at the arrowed end, so that is on my (well, JagCare's) to-do list.

  18. Thanks #steve thanked for this post
    Likes #steve liked this post
  19. #150
    Senior Member #steve's Avatar
    Join Date
    Feb 2017
    Location
    Middlesbrough
    Posts
    802
    Post Thanks / Like
    That sticky thing is a rear tie-rod and it does need fixing.
    2010 Jaguar XJ V8 Portfolio.

Page 15 of 15 FirstFirst ... 51112131415

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •