Results 1 to 5 of 5

Thread: F Type Radio

  1. #1
    Junior Member
    Join Date
    Jan 2020
    Location
    Naples, FL
    Posts
    3
    Post Thanks / Like

    F Type Radio

    Hi, I need some help with my 2015 F Type. Recently two things are happening with my radio. After about 2 minutes after startup the radio stops and the screen reads audio off. If I touch the screen all is fine for the rest of the trip. Second, at variable times after shutdown the radio starts up by itself. I have to press the ignition button twice to shut it down or let it operate for about 6-8 minutes at which time it shuts off on its own. How often this is happening over a 24 hour period I don't know but this will be a battery killer. Also regarding the second issue, pressing the radio off button has no effect. I tried disconnecting the battery but no effect as well. Any thoughts?

  2. #2
    Senior Member OzJagXFS's Avatar
    Join Date
    Oct 2013
    Location
    Adelaide South Australia
    Posts
    1,124
    Post Thanks / Like
    Never heard of this problem before and I have been following F-Type issues for several years.
    The majority of Jag electrical system problems are caused by a weak battery so the first thing to try is to connect up a battery tender overnight to bring the battery up to full charge. CTEK are a popular brand around here.
    Also you will get more advice over on the US forum, way more F-Type owners there: https://www.jaguarforums.com/forum/f-type-x152-72/
    2014 F-Type S coupe, Lunar Grey, red seats and nearly all the options.
    The dearly departed - 2010 XFS and 2010 XFR.

  3. #3
    Junior Member
    Join Date
    Jan 2020
    Location
    Naples, FL
    Posts
    3
    Post Thanks / Like
    Quote Originally Posted by OzJagXFS View Post
    Never heard of this problem before and I have been following F-Type issues for several years.
    The majority of Jag electrical system problems are caused by a weak battery so the first thing to try is to connect up a battery tender overnight to bring the battery up to full charge. CTEK are a popular brand around here.
    Also you will get more advice over on the US forum, way more F-Type owners there: https://www.jaguarforums.com/forum/f-type-x152-72/

    Hmm. The battery is almost 6 years old so I will try that. Thanks

  4. #4
    Junior Member
    Join Date
    May 2020
    Location
    Zürich
    Posts
    1
    Post Thanks / Like
    most likely there was a breakdown of the dielectric on the case
    Meine Nachrichten über Spiele

  5. #5
    Junior Member
    Join Date
    Jan 2020
    Location
    Naples, FL
    Posts
    3
    Post Thanks / Like
    I sort of solved the issue. So long as I never turn off the radio, but just turn down the sound as necessary, the radio behaves. Not perfect but workable. I believe the problem is in the switch. I also own an F Pace and the switch on it is very responsive while the one on my F Type feels sticky.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •