Results 1 to 5 of 5

Thread: Radio issue

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    7
    Post Thanks / Like

    Radio issue

    Got a strange issue.

    Original radio worked as in it turned on, but volume control stopped working.
    So after not being able to locate brand new radio, found a used one.
    Installed it, it didn't power on at all. Ok...so maybe it is a dud.
    So reinstalled original radio, now it doesn't power on either.
    Ground is tight, fuses good. Circuit in intact.

    Anyone ever came across this issue and solved it?

    1996 xj12 with Harmon kardon.

  2. #2
    Junior Member
    Join Date
    Dec 2018
    Posts
    7
    Post Thanks / Like
    alright. Got it working. Just to see what would happen, disconnected ground from battery, reconnected and...lo and behold, radio got power.

    Sadly, the used radio was a dud. Powered on, but wouldnt switch from tape player mode and constant flipping of tape, even if no tape inside.

    So the search continue for replacement radio.

  3. #3
    Member
    Join Date
    Dec 2015
    Location
    Ottawa, Canada
    Posts
    33
    Post Thanks / Like
    Hello
    It may be an issue of getting the code re-set by a Jaguar dealer.
    Regards
    Richard

  4. #4
    Junior Member
    Join Date
    Dec 2018
    Posts
    7
    Post Thanks / Like
    Yeah I thought that. I know the x40 radios need code. And the x308 radios need code. But both of those usually display CODE. These two did not. it would be strange if jaguar skipped code mechanism just for the x300/x305

  5. #5
    Junior Member
    Join Date
    Dec 2018
    Posts
    7
    Post Thanks / Like
    Once l hunt down a known working one, it will be clear

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •