Results 1 to 8 of 8

Thread: Weird problem with overhead light module in Jaguar S-Type 2002

  1. #1
    Junior Member
    Join Date
    May 2020
    Location
    Poland/Poznan
    Posts
    4
    Post Thanks / Like

    Weird problem with overhead light module in Jaguar S-Type 2002

    Hi,

    Since I bought S-Type, I've been struggling with a strange problem. The point is that the front middle bulb in the overhead module does not light up. Right/left in the front or rear work good. However, when I light up the right and left front at the same time, the middle one also starts to light up, although then they all weaken. I was with it in Jaguar's authorized service in Poland and they said that the module is broken. So I replaced it and bought new Philips halogen bulbs. Unfortunately the problem did not disappear. Below I attach a link video in gdrive of what I mean exactly. Please help me to identify the problem 🙂

    https://drive.google.com/open?id=1X3...0kEbPjJYBiHf84


    Cheers
    nortalix

  2. #2
    Senior Member
    Join Date
    Jun 2009
    Location
    Manchester UK
    Posts
    1,817
    Post Thanks / Like
    Strange issue. The map lights (left and right) in the roof console are not controlled by any module, they are a simple power > switch > bulb setup.
    The middle courtesy light is controlled by a module and that's why it fades out and the map lights don't.
    So they are not really connected to each other, or they shouldn't be. I imagine there is a short in the wiring somewhere. The wiring diagrams are in the stickies section I think.
    2007 S type R, Radiance Red/ Champagne, all options but for the sunroof. Oh, and the garage door opener.
    Added MP3 audio connectivity module.

  3. Thanks nortalix thanked for this post
  4. #3
    Senior Member FlatCap's Avatar
    Join Date
    Feb 2019
    Location
    West Yorkshire
    Posts
    1,197
    Post Thanks / Like
    I had same, my sunroof drains were blocked so i had water getting on the PCB.
    Rhubarb, 2003 Super V8 Radiance Red,Sepangs, Iron Fist Velvet Glove. I am not a car guy.


    Going back thru time
    Volvo V70 D5-Gary
    Bmw 530d E39
    Bmw 520d touring F11
    Bmw 330d touring F31
    Bmw 330d coupe E92
    Volvo 960 Cd estate, greedy bugger
    Mercedes W124 300d multivalve,loved the chip fat
    Porsche 997 C2
    Honda Civic Cdti
    Astra 1.6
    Jeep Grand Cherokee
    VW Golf GTDi
    Subaru Impreza Turbo Terzo
    Mazda MX6
    Carlton 2.0 Cdi
    Mercedes 190e
    Orion Ghia i
    Audi 90 2.2
    Mini

    10 vans and a Jcb 533 105

  5. #4
    Junior Member
    Join Date
    May 2020
    Location
    Poland/Poznan
    Posts
    4
    Post Thanks / Like
    OK i will check with multimeter if there is a short in the wiring. Does somebody have link to schema ?

  6. #5
    Senior Member
    Join Date
    Jun 2009
    Location
    Manchester UK
    Posts
    1,817
    Post Thanks / Like
    If you google electrical guide s type jag I'm sure you'll find it.
    Attached Thumbnails Attached Thumbnails Screenshot (34).png   Screenshot (36).png  
    2007 S type R, Radiance Red/ Champagne, all options but for the sunroof. Oh, and the garage door opener.
    Added MP3 audio connectivity module.

  7. Thanks payno thanked for this post
  8. #6
    Senior Member Jimbov8's Avatar
    Join Date
    Apr 2013
    Location
    Worksop
    Posts
    13,633
    Post Thanks / Like
    Here is the complete electrical manual for your car. http://www.jagrepair.com/images/Auto...x2032002en.pdf
    Jim.
    2012 XKR Black pack, Speed Pack, Aero pack, Rat pack. Past:-87'XJS 3.6L, 93'XJ40 3.2L gold, 95'XJ6 4.0L sport, 00'XJ8 3.2L sport, 2005 XK8 4.2L coupe, 2009 XK 5.0L Portfolio in that order and enjoyed all of 'em.

    I do not offer advice, I only say what I would do with the set of circumstances presented. Your choice always.

  9. Thanks payno thanked for this post
  10. #7
    Junior Member
    Join Date
    May 2020
    Location
    Poland/Poznan
    Posts
    4
    Post Thanks / Like
    Problem solved. There was a burned path on the pcb

  11. Likes stanboy liked this post
  12. #8
    Junior Member
    Join Date
    May 2020
    Location
    Poland/Poznan
    Posts
    4
    Post Thanks / Like
    Bad news. Paths on PCB keeps burning out ( 5th time yesterday ... ). Current on middle bulb is 0.33A ( good ). Maybe there's ground problem? I know that harness from that roof panel goes to instrument cluster but could anyone help me to find where i can find nearest ground spot?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •