Page 1 of 4 1234 LastLast
Results 1 to 10 of 39

Thread: Just bought a xj8 2006 that won't start.

  1. #1
    Junior Member megatrack's Avatar
    Join Date
    Sep 2020
    Location
    USA
    Posts
    19
    Post Thanks / Like

    Just bought a xj8 2006 that won't start.

    Here is what I know, it was sitting indoor for 8 months previous owner decided to start it so he charged the battery and started the car, went to fill it up at the gas station and could never start it again. Any idea? I am thinking by moving the car bad stuff in bottom of thank clogged the pump?

  2. #2
    Senior Member FlatCap's Avatar
    Join Date
    Feb 2019
    Location
    West Yorkshire
    Posts
    1,722
    Post Thanks / Like
    Does the fuel pump run?
    Rhubarb, 2003 Super V8 Radiance Red,Sepangs, Iron Fist Velvet Glove. I am not a car guy.


    Going back thru time
    Volvo V70 D5-Gary
    Bmw 530d E39
    Bmw 520d touring F11
    Bmw 330d touring F31
    Bmw 330d coupe E92
    Volvo 960 Cd estate, greedy bugger
    Mercedes W124 300d multivalve,loved the chip fat
    Porsche 997 C2
    Honda Civic Cdti
    Astra 1.6
    Jeep Grand Cherokee
    VW Golf GTDi
    Subaru Impreza Turbo Terzo
    Mazda MX6
    Carlton 2.0 Cdi
    Mercedes 190e
    Orion Ghia i
    Audi 90 2.2
    Mini

    10 vans and a Jcb 533 105

  3. Thanks megatrack thanked for this post
    Likes thebiglad liked this post
  4. #3
    Senior Member Dodsy's Avatar
    Join Date
    May 2012
    Posts
    417
    Post Thanks / Like
    Simple things first - Disconnect the battery for 30 seconds and reconnect to reset all the electronics, Jags get very upset by low battery voltage. Also give the gear stick a wiggle make sure its fully in park - - you should get warning noises if its not in park but weirdly I have had it happen to me and got no warning noise.

    When the ignition is turned on does it throw up any fault messages ?

    As pre previous post listen for the fuel pump. IME 'crap in the fuel tank' doesn't happen in modern cars plus there is a strainer and fuel filter, But (and there is always a but) fuel can go off and water can get into the tank so if nothing else jumps out as a problem, drain and refill the tank might me worth a go.
    2007 XJR

  5. Thanks megatrack thanked for this post
    Likes thebiglad liked this post
  6. #4
    Senior Member Fraser's Avatar
    Join Date
    Jun 2010
    Location
    Crewe, Cheshire, UK
    Posts
    1,555
    Post Thanks / Like
    The tank is plastic, so no internal rusting. The seller's story seems odd; the car started OK and got to the filling station, then conked out ? So presumably it was recovered back to the owner's house. Maybe he filled up with diesel !
    Fleet manager (!!) of: -
    XE Portfolio 180 AWD 2017
    VW New Beetle 2009
    MG Midget 1500 1977
    MG TF 135 2010

  7. Thanks megatrack thanked for this post
  8. #5
    Senior Member
    Join Date
    Jun 2009
    Location
    Manchester UK
    Posts
    2,546
    Post Thanks / Like
    +1 for the battery reset. Maybe touch the negative and positive cables together when removed from said battery.
    Try to start again, then read codes.
    I'm guessing by the use of the words 'Gas' and 'Station' that all of this occurred in the colonies. Where it is less likely that the car was accidentally filled with diesel.
    2007 S type R, Radiance Red/ Champagne

  9. Thanks megatrack thanked for this post
    Likes thebiglad liked this post
  10. #6
    Junior Member megatrack's Avatar
    Join Date
    Sep 2020
    Location
    USA
    Posts
    19
    Post Thanks / Like
    Thank you I will check that and update.

  11. #7
    Junior Member megatrack's Avatar
    Join Date
    Sep 2020
    Location
    USA
    Posts
    19
    Post Thanks / Like
    Ok , I checked for codes .I have c1175,P1638 and P1642.
    I did disconnect the battery and touch 2 cable together. I cranks but not trying to start at all. Any thought?

  12. #8
    Senior Member Jimbov8's Avatar
    Join Date
    Apr 2013
    Location
    Worksop
    Posts
    14,233
    Post Thanks / Like
    C1175 = left hand rear wheel speed sensor.
    P1638 = ECM lost communication with instrument cluster.
    P1642 = Can circuit malfunction ( May relate to P1638 ).

    Also Check the inertia switch hasn’t tripped.
    Jim.
    2012 XKR Black pack, Speed Pack, Aero pack, Rat pack. Past:-87'XJS 3.6L, 93'XJ40 3.2L gold, 95'XJ6 4.0L sport, 00'XJ8 3.2L sport, 2005 XK8 4.2L coupe, 2009 XK 5.0L Portfolio in that order and enjoyed all of 'em.

    I do not offer advice, I only say what I would do with the set of circumstances presented. Your choice always.

  13. Thanks megatrack thanked for this post
  14. #9
    Junior Member megatrack's Avatar
    Join Date
    Sep 2020
    Location
    USA
    Posts
    19
    Post Thanks / Like
    Inertia switch has not tripped. Any idea where to start?
    Thank you for helping.

  15. #10
    Senior Member FlatCap's Avatar
    Join Date
    Feb 2019
    Location
    West Yorkshire
    Posts
    1,722
    Post Thanks / Like
    Does the fuel pump run?
    Rhubarb, 2003 Super V8 Radiance Red,Sepangs, Iron Fist Velvet Glove. I am not a car guy.


    Going back thru time
    Volvo V70 D5-Gary
    Bmw 530d E39
    Bmw 520d touring F11
    Bmw 330d touring F31
    Bmw 330d coupe E92
    Volvo 960 Cd estate, greedy bugger
    Mercedes W124 300d multivalve,loved the chip fat
    Porsche 997 C2
    Honda Civic Cdti
    Astra 1.6
    Jeep Grand Cherokee
    VW Golf GTDi
    Subaru Impreza Turbo Terzo
    Mazda MX6
    Carlton 2.0 Cdi
    Mercedes 190e
    Orion Ghia i
    Audi 90 2.2
    Mini

    10 vans and a Jcb 533 105

  16. Thanks megatrack thanked for this post
Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •