Page 126 of 126 FirstFirst ... 2676116122123124125126
Results 1,251 to 1,253 of 1253

Thread: Android upgrade to Jaguar Touchscreen for XJ X350/X358, S-Type and X-Type - HOWTO

  1. #1251
    Senior Member Grrrmachine's Avatar
    Join Date
    Dec 2015
    Location
    Warsaw, Poland
    Posts
    118
    Post Thanks / Like
    The pictures at the start are dead because they're redundant: Ben's method has changed significantly since those days, so all the required pics are on his website.

    I took my system on a near-1000km roadtrip this weekend, which served as a bit of a shakedown test. It was great having the factory navpanel back in the car compared to my previous setup, since I had all the cool climate and audio controls again. Google maps was a nice change too (I used to use Mapfactor Navigator), but that annoying Yank voice has to go - she chirped "there's congestion ahead!" every 10 minutes during a 2 hour traffic jam until I turned the stereo off to shut her up. Stating the ****** obvious would be an understatement.

    But the trip brought up a few niggles that I need to find fixes for:


    • Random voice activation - sometimes the system worked flawlessly for hours on end, while other times the Arduino triggered the Jag's voice Listening command so often that I had to force the Odroid power off to shut it up. It only happens when the unit is set to Android mode: pressing AUDIO or CLIMATE stops this from happening (which seems odd if the Arduino is constantly polling the steering wheel button input).
    • Steering wheel controls are unreliable. Despite running the config program multiple times, the buttons had trouble detecting proper Up and Down track skip signals, and I think also picked up incorrect commands from other buttons (i.e. Vol Down triggered Play Next).
    • Screen switching was... chaotic. This, I think, is due to the parking camera I added to AV1 - after a day the RTD board got confused about which signal it was supposed to switch between, meaning that if you pressed NAV it showed the android screen for less then 2 secs before showing the original VGA signal again, no matter what I did. Turning off the car for a bit, then selecting reverse occasionally fixed things but I haven't nailed down the exact sequence for duplicating and fixing this problem.


    I think I can fix the first two issues by hard-coding the values for the steering wheel controls, but I might try upgrading to Ben's v4 method first to separate the Arduinos. As for the screen signal switching: I can either try using AV2 for the parking camera instead, or I need to look at the tokens I'm storing for the sleep command to see if something's getting scrambled when the system wakes up again.
    2004 X-Type 3.0 Executive Estate, Pacific Blue with Champagne Leather and CarPC install.

  2. #1252
    Senior Member
    Join Date
    Apr 2015
    Location
    Hertfordshire
    Posts
    830
    Post Thanks / Like
    Had a smell of electrical burning the other day. Suspecting it was something to do with the Jagdroid mod I took the HU out yesterday and discovered this!

    I've moved the resistors out of the way to show the damage ..... ho hum!

    Click image for larger version. 

Name:	20190818_170203.jpg 
Views:	1 
Size:	587.4 KB 
ID:	31533
    2005 STR
    Upgrades:-
    Adamesh Exhaust
    2003 S Type V8 SE

    Retrofits:- Voice, premium amp, ACM, bluetooth, OEM park sensors, auto wipers, STR rear lights, rear blind, OEM spoiler, XF stalks
    Upgrades:- Jagdroid, reverse camera, Autofold mirrors, Audiocontrol LC8i, JL Audio XD7005v2 amp, JL Audio C3-650 front, JBL coax rear, JL Audio 6W3v3-4 (x2) subs, Alpine Ezi-DAB, LED interior, mesh grills, Adamesh exhaust

  3. #1253
    Senior Member MarkFY's Avatar
    Join Date
    Jan 2017
    Location
    Thornton-Cleveleys, Lancashire
    Posts
    2,150
    Post Thanks / Like
    Quote Originally Posted by Grrrmachine View Post
    T
    But the trip brought up a few niggles that I need to find fixes for:


    • Random voice activation - sometimes the system worked flawlessly for hours on end, while other times the Arduino triggered the Jag's voice Listening command so often that I had to force the Odroid power off to shut it up. It only happens when the unit is set to Android mode: pressing AUDIO or CLIMATE stops this from happening (which seems odd if the Arduino is constantly polling the steering wheel button input).
    I had this in the early days, I fitted a switch to to break the 'steering wheel' connection incase it happened on a long journey. After the CD/Radio mod with the Arduino pro this has never been a problem since.

    Quote Originally Posted by Grrrmachine View Post


    • Steering wheel controls are unreliable. Despite running the config program multiple times, the buttons had trouble detecting proper Up and Down track skip signals, and I think also picked up incorrect commands from other buttons (i.e. Vol Down triggered Play Next).
    The latest version does not require calibration and I can't remember the last time track or vol up/down didn't do what was requested.

    Quote Originally Posted by Grrrmachine View Post



    • Screen switching was... chaotic. This, I think, is due to the parking camera I added to AV1 - after a day the RTD board got confused about which signal it was supposed to switch between, meaning that if you pressed NAV it showed the android screen for less then 2 secs before showing the original VGA signal again, no matter what I did. Turning off the car for a bit, then selecting reverse occasionally fixed things but I haven't nailed down the exact sequence for duplicating and fixing this problem.
    Despite having front and rear cameras (AV1 and AV2 inputs) connected I've never had a problem with switching. Unit has been in the car for 19 months now. Perhaps you have a flakey RTD board or dodgy SDA/SCL connections to the RTD?

    Quote Originally Posted by Grrrmachine View Post



    I think I can fix the first two issues by hard-coding the values for the steering wheel controls, but I might try upgrading to Ben's v4 method first to separate the Arduinos. As for the screen signal switching: I can either try using AV2 for the parking camera instead, or I need to look at the tokens I'm storing for the sleep command to see if something's getting scrambled when the system wakes up again.
    Look at the latest version/code as calibration is no longer required.
    X-Type Sport 2.5 V6 AWD Auto MY2002 80,300mls Platinum Cranberry leather sports seats

    www.xtype.uk - For Everything X-Type

    Retrofits: Climate Control (from manual ac), touch screen, LED interior, facelift steering wheel, bluetooth, voice, message centre, facelift center console/sliding arm rest, ACM, facelift door cards, powerfold mirrors, powerfold on lock, clear side repeaters, puddle lights, rear electric windows, parking aid, JagDroid, front/rear cameras, Nextbase 522GW+Rear Dashcam

Page 126 of 126 FirstFirst ... 2676116122123124125126

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •