Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Replacing HID to LED

  1. #11
    Junior Member
    Join Date
    Nov 2018
    Location
    Slovenia
    Posts
    2
    Post Thanks / Like
    Hello,

    I am also owner of XF X260 that was bought in Germany and only thing I am missing on my beloved Jag are LEDs, so I looking at replacing my Xenons for LED headlights. Can you guys who made similar conversion confirm that replacement is working without any issues now that you had this replacement for a while and that all you did was just "plug and play" new LED headlight.

    I am a bit concerned before making a purchase as dealers that sell those LED headlights don't have consistent answers regarding modifications required (some want to charge additional 200GBP for modifications, others saying it takes lots of drilling and rewiring...). Also, could you share exact part number of LED headlights you have now as I see there are some variations on models available on internet - GX63-13W029-LF, GX63-13W029-LA, GX63-13W029-LB.... all for EU spec headlights and I don't understand what differences are (if any).


    Thanks,
    Andrej

  2. #12
    Junior Member
    Join Date
    Sep 2018
    Posts
    3
    Post Thanks / Like
    Hi Andrej
    Yes I have fitted the full LED headlight in my x260 the fitment is straight forward they just bolt in exactly the same you can just plug them in and they function as normal only issue you will have is the indicators inside the car will be fast as if a blub has blown has blown. I got round this with some load resistors it's is all plug and play no wiring mods at all

    Ian

  3. Thanks andrejk thanked for this post
    Likes andrejk liked this post
  4. #13
    Junior Member
    Join Date
    Nov 2018
    Location
    Slovenia
    Posts
    2
    Post Thanks / Like
    Thanks Ian,

    I went forward with purchasing LEDs and as you said they fit perfectly nice and they work as expected. I noticed issue with fast indicators inside car, same as you did. If you can share some more light on how to fix this that would be perfect.

    Another thing I noticed - and just wondering this is also happening in your case - is that after turning car on, even if just day LEDs are turned on for a while, there is hum coming from both headlights, as there was kind of fan inside cooling them off and this goes on for couple of minutes. I assume this is normal, but I haven't noticed this on my previous car (not Jag) with LEDs.


    Thanks,
    Andrej

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •