Jaguar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-15 of 15 Results
  1. XJ (X350, X358) Aluminium Body 2003 - 2009
    I drive a 2007 XJ 2.7 Diesel. The battery was replaced with a new Varta unit 5 months ago. The battery negative cable was replaced 4 months ago as it was knackered and causing slow cranks and flickering lights. My problems started a week or two ago. I was driving to work and randomly got a...
  2. S-Type (X200, X202, X204, X206) 1999 - 2008
    Hey guys I’m new here. I own a 2002 Jaguar s type with the 4.0 v8. I recently got my coolant reservoir changed and I see a plug that is now disconnected. It’s located on the brake booster and will be attaching a picture. If someone can please tell me what connector this is and where to find the...
  3. X-Type (X400) 2001 - 2009
    Recently went for a drive in my 2007 2.2 X type, and upon turning on the ignition, the ABS warning light, and DSC system fault message came up. These warnings come on before the car even starts moving. I've checked the front wheel speed sensors, and have cleaned them, however the warnings still...
  4. X-Type (X400) 2001 - 2009
    Greetings, hope someone can help! The above fault came up a few days ago. I plugged in my code reader, my sons, even bought another cheap and cheerful one from the net: 'No code found' on all. I'm assuming that these readers only read engine management codes and that the DSC fault is...
    dsc
  5. S Type Stickies
    From time to time like today, we come across something interesting that's not related to the problem we're chasing and we don't want to lose that video or info. So this might be a good place to store them for browsing or until needed. Here's the first few... Throttle body connector causing...
  6. XK / XKR (X150) 2006 - 2014
    Hi all, I've been trying to research my problem for the last week and can't seem to find an answer to my issue (or at least not one that I like!) Car: X150, 4.2 NA, Coupe, 2007, under 20,000 miles The car has been parked in the garage for the last 3months I reckon, as there has been a lot of...
  7. S-Type (X200, X202, X204, X206) 1999 - 2008
    Hello. I have a 2006 jaguar s type with 135000 miles on it. Recently it acted like it was gonna die after putting it in drive from park. Shortly after that I noticed my red and amber light show up. With messages brake fluid low, dsc not available, parkbreak fault, brake assist fault and abs...
  8. X-Type (X400) 2001 - 2009
    HI After solving my canbus issue i got a lot of new troubles. Abs lamp, handbrake,brake, and motor lamp is on in the dash. It seems to me that this is ABS related problem. Fault code is p0500, lack of speed sensor unit.... The main problem is that fuse 13, f13, is blowing. ABS control system...
  9. S Type Stickies
    Laszlo Woodbine designed a simple ABS Sensor tester which anyone can make and use to isolate a faulty ABS sensor without changing random ones on speculation, but hasn't been on the forum since, so it's good to have a link here in our Stickies to that thread so it can be found. The front ABS...
  10. Dsc

    XF / XFR (X250) 2007 – 2015
    Hello! I have a Jaguar. The car is very reserved, but appears a problem I can not solve. Occasionally the DSC lights up and the car goes into emergency mode. Several times the error had been fixed in the auto garage, but it continued to appear. I do not know what to do. Please if anyone has had...
    dsc
  11. XF / XFR (X250) 2007 – 2015
    Hello all, Looking for help or suggestions, my DSC light has come on again with restricted performance this has append a few times, but always cleared after starting, have noticed its come on after driving over speed bumps slowly. On this occasion its come on with the check engine light with...
  12. XK / XKR (X150) 2006 - 2014
    Hi all, Started my 4-year old 5.0 XK last night and the dashboard lit up amber - warning lights and messages showing no DSC, no ABS, and no Adaptive Dynamics. I've read a lot of posts about the electronics going wonky in the cold - anyone got experience of this, do you think this might just...
  13. S-Type (X200, X202, X204, X206) 1999 - 2008
    Chaps, I'm aware other people have had issues with this, but I'm struggling to find any real resolution. I've had the warning on the dash for several months now, and I've been trying various things to try and clear / sort out the problem. I've checked all 4 wheel sensors, and they appear to be...
  14. XF / XFR (X250) 2007 – 2015
    I have seen others reporting these diagnostic faults appearing in the display. I have had this several times and on turning off the ignition, waiting and then restarting I get Gear Box Fault. A further turn off and re-start clears the displayed fault. So today my car went into the dealer at...
  15. S-Type (X200, X202, X204, X206) 1999 - 2008
    Hi all, just thought i would comment on my repairs to the above problem. This came up on the dash and had to go to the local garage to find out what it was, paid money out just for that and was told it could be lots of things. As i intended to keep my 2003 auto stype and i can do most repairs i...
1-15 of 15 Results
Top