Jaguar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. X-Type (X400) 2001 - 2009
    Hello dear friends and Jaguar Enthusiast, My xtype seem have the turbo actuator dead. I have try to check manually at idle speed reving the motor to see if the actuator move... But its not moving. Is anyone can do the test and let me know if at idle, hood open, one people at engine reving...
  2. X-Type (X400) 2001 - 2009
    Hi all, Quick question: I'm aware that Jaguar changed the fog light unit to different style (along with the bulbs from H1 to H11), but I was wondering if the newer design like this...
  3. X-Type (X400) 2001 - 2009
    Hey guys, I'm a new owner of a 2002 Jaguar X-type 3.0 with 160,XXX miles. Although I would love to say that I'm out daily burning rubber or however the saying goes, things are far from sunshine and daisies for me here in sunny San Diego. Now I'm not sure whether or not this should be in the new...
  4. X-Type (X400) 2001 - 2009
    My 2004 Jaguar X Type 3.0 AWD only has 90,000 miles. When I accelerate and drive the car feels bumpy out of nowhere. I am trying to figure out what it is. I don't think the previous owner ever changed the shocks, could it be that or the springs? Someone please help !!:(
  5. X-Type (X400) 2001 - 2009
    Hi I own a 2005 jaguar x type 3.0 and I want to purchase chrome wiper arms and blades. Can anyone help me find this product? Auto parts stores, jaguar dealership, and the inter et hasn't really helped so far..
  6. X-Type (X400) 2001 - 2009
    The radio in my X type changed itself from classic FM onto a medium wave as I was passing through a busy street in the city centre and was stuck at that channel, I tried pressing all the buttons to change the frequency but was not lucky. Finally I decided to disconnect the battery and reconnect...
  7. New Members Introduce Yourself Here
    Hello everyone. I'm Tony, I live in the West Midlands and I own a very pretty X-Type SE 2.5 v6 AWD. This is my first Jag having admired them for many years though I expect it will be the first of many. :cool:
  8. X-Type (X400) 2001 - 2009
    Over past few months have had some issues around starting the car. Seems to fail starting sometimes when turning the key ignition. Any pointers around why it fails to start sometimes? Is it Glow Plugs? Batt Fault or Alternator? Starter Motor was changed around 3 years ago.
1-8 of 8 Results
Top