Jaguar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-14 of 14 Results
  1. X-Type (X400) 2001 - 2009
    Hello dear Jaguar owners friends, i am a pro car mechanic and a Jaguar enthusiast. I actually just pass the 300000 kms with my xtype 2005 2.0D , and she run very good for his old age. But, recently with the cold weather (3deg celcius), the fuel fired booster heater give me an excessive smoke...
  2. X-Type (X400) 2001 - 2009
    Hi, my 2004 X Type diesel estate has been sat in a friends garden for the last 18 months. It failed the MOT so my friend dropped the tank to do welding. He did it but i'm sure he just put the tank back and disturbed the 162k miles worth of gunk. I've now cleaned the whole diesel delivery route...
  3. X-Type (X400) 2001 - 2009
    Hi I am new to the forum and hope (1) I am in the right place, (2) Someone can help! I bought my x type diesel sport a few months ago. Naturally since looking for one I was over the moon when I got it. At first I couldn't get enough of it but as time as gone on I don't enjoy the car but so much...
  4. X-Type (X400) 2001 - 2009
    drove the x type diesel for about 45 minutes,all good put the aircon on and 5 minutes later burning smell and smoke billowing out. Turned the engine off waited for it to cool and looked at the belt ,seems fine. I started the car,air con off and got home no problem. Put the aircon on and smoke...
  5. X-Type (X400) 2001 - 2009
    My X (2007 2.0d), is giving me a headache! It takes a lot of cranking to get it to do something, and when it does fire there's a lot of white smoke out of the back, it runs for about 10-20 seconds before cutting out again. I was told that it was the fuel pressure valve, but changing it hasn't...
  6. XJ-S / XJS 1976 – 1996
    Hi all, this is my first post as I'm new here! Wonder if I could pick your brains on a couple of issues I'm experiencing with my 88' xjs 3.6 manual. a few months ago after an hour or so of motorway driving, when slowing down to city traffic I noticed my revs had increased to 1000 rpm +/-10% and...
  7. XJ6 / XJ12 / XJR (X300, X330, X305, X306) 1994 – 1
    Hello All, I am hoping someone can point me in the right direction for a problem I have having. When I leave my car to idle in park I get quite a lot of blueish smoke coming out the back of the exhaust. It only seems to do this when in park and not in drive as I can sit in traffic on the foot...
  8. X-Type (X400) 2001 - 2009
    I went on the school run yesterday and the car was a bit unresponsive. When i pulled into a car park it started to rev and smoke poured out. I turned the key off and the car continued to run so had to stall the engine. I was advised by the recovery company the turbo was cattled and would cost...
  9. X-Type (X400) 2001 - 2009
    Hi I have a x type 2.0d 2007 and i am having problems with the car on startup. When i start the car it is very lumpy like it was n't firing on all cylinders or something like, also it kicks out a good cloud of smoke (white/blue) . It soon settles down after 1 or 2 mins and then runs fine when...
  10. X-Type (X400) 2001 - 2009
    Hello I have a 2.0D xtype 2007 with11500 miles on the clock. When i start it from cold or when its been left for a couple of days there is quite a cloud of white smoke that comes from the exhaust. After a few seconds the smoke clears and runs ok to my knowledge maybe a bit lumpy at first but...
  11. X-Type (X400) 2001 - 2009
    As the description says. I was driving up the A27 when the car lost a lot of power, no turbo, and started belching grey (not black ) smoke. It's not long had a new head, timing chain, tensoners, injectors, filters. There has been a bit of a whine coming from the turbo recently. Any ideas chaps?
  12. X-Type (X400) 2001 - 2009
    Hi all, Fuel economy has not been great on my 2007 2.0D (135k miles). Only getting about 37mpg combined, and there is plenty of smoke under heavy load. So decided to clean the EGR Valve. Straight forward job - I used the guide here on the forum to familiarise myself with whats what. When I...
  13. X-Type (X400) 2001 - 2009
    Hi, I am new to this site and looking for some advice on what may be wrong with my X-Type Jaguar and what course of action should I take. I have listed the symptoms below, these have gradually increased over time (12+ months), culminating with the starting issues and smoke on start-up. I'm...
  14. S-Type (X200, X202, X204, X206) 1999 - 2008
    Hi - I have a 2005 s-type 2.7D. Been to main dealer numerous times, but they have been unable to fix. I had exhaust fumes coming into cabin. Valve covers identified as leaking and replaced. Now burnt oil smell and smoke wiffs from under bonnet (rear/near side - below fuel filter(?)) and...
1-14 of 14 Results
Top