Jaguar Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-11 of 11 Results
  1. XF / XFR (X250) 2007 – 2015
    Hello, I'm looking for help finding out the part number of a hose I've identified leaking on my car. I't the short hose connecting from the bottom of the Pressure Relief Thermostat to the radiator as seen in the picture. Any help much appreciated. Thanks
  2. X-Type (X400) 2001 - 2009
    Hi all, I have a very frustrating problem with my 2.0D X-Type temperature gauge. Story goes that I came back from holiday and was driving down the motorway. Temp gauge got into the red and I managed to get some more coolant from a local (to Heathrow) Jag garage as a "get me home" which did the...
  3. S-Type (X200, X202, X204, X206) 1999 - 2008
    Hi Jag fans I have a 2003 STR . About two weeks ago I had a ' Low coolant level " warning come up. The level of coolant was about 2 inches below the min level so I topped it up. Last week whist driving on the motorway about 15 mins and 10 miles into a journey I had an error P0116...
  4. X-Type (X400) 2001 - 2009
    Hello, As many Jaguar X-type owners seems to have an issue with the engine temperature not being stable or not get warm enough, I'll throw another question into the mix. Can a coolant sensor go faulty only after 18 months? What is your experience/advice? I bought a 2008 X-type 2.2 diesel just...
  5. XF / XFR (X250) 2007 – 2015
    As title suggests, has anyone with an XFR or the 5.0 V8 NA had their thermostat changed? If so, how long did it take and cost? Thanks
  6. X-Type (X400) 2001 - 2009
    I'm having a problem getting my 2.2 ( with DPF) up to 12 o'clock on the gauge in this cold weather. It will after Tickover for 30mins + 5-10 miles driving on high revs ( not easy on an auto)reach 1/4 - then perhaps a further hour of stationary with some revs to reach normal. In my normal driving...
  7. XK8 / XKR (X100) 1996 - 2005
    Hi, I've just taken the 1998 XKR out of mothballs for the year with a view to getting it back on the road soon. I've had a few issues with it recently, and am now a bit worried that the car may be running too hot. When driving it from where it was stored to a workshop a few hundred yards away...
  8. New Members Introduce Yourself Here
    Hi All, I have just recently picked up a 2005 X Type 2.0l Diesel Estate SE and I have to admit I am very impressed. There are a few 'niggles' which I hope to iron out over next few weeks. Firstly, on the drive home from buying it, I noticed quite a strong smell of oil... having completed an...
  9. X-Type (X400) 2001 - 2009
    Hi All, First post here. In fact posting on behalf of my father in law who has an 2002 X-Type with a strange issue. The passenger headlight doesn't work. Thought it would be the usual a blown bulb but changed it and it still doesn't come on. Checked the fuse and yup it had blow, replaced this...
  10. X-Type (X400) 2001 - 2009
    Two weeks ago I noticed on my 2007 X 2.0D that the water temperature needle in the dash is unusually low. This was about two weeks after I did a full service (first in my ownership of 11 months) during which the mechanics at the garage, without asking me about it, poured some K-seal. I was very...
  11. XJ6 / XJ12 / XJR (X300, X330, X305, X306) 1994 – 1
    Can anyone help me? I have searched the threads but can't find an answer. The fans are blowing great, the A/C works fine but the temp guage hardly moves at all and I have zero warm air. I had a little, barely warm air for a while but now nothing, just cold. Is it my thermostat or what is going...
1-11 of 11 Results
Top