03 S type Aftermarket Stereo No Sound

Dalgo

New member
Joined
Apr 4, 2021
Messages
8
Reaction score
1
Points
3
03 S type Aftermarket Stereo No Sound

I’ve Recently bought a New Kenwood DMX47075 DD head unit to replace my stock radio and a Metra 70-9500 Wire harness to to attach. According to different threads and videos I’ve connected all wires correctly between stereo and harness. When I plug unit to the car all the Features are fully functional but has no sound at all. I plug Out aftermarket radio and plug in factory radio then sound works perfectly again 😩 Help Please
 

Dalgo

New member
Joined
Apr 4, 2021
Messages
8
Reaction score
1
Points
3
I’m pretty sure the system is Alpine and it is amplified but I’m not sure if its Premium or standard
 

M-e-l-l-o-w

Member
Joined
Apr 21, 2015
Messages
376
Reaction score
15
Points
18
Location
Essex
I thought that may be your problem.

If you do have the amp then the speakers are connected to the amp in the boot only not the head unit. The amp in the boot is connected to the head unit via the d2b fiber optics, not via the speakrer wires.
You will not be able to use an aftermarket head unit to power the amp in the boot. There are no speaker wires from the head unit to the amp.

The speakers for the system without the amp in the boot use diferent wires and plugs in the doors that go to the head unit.

The only way you can get an aftermarket head unit to work in an s-type is to remove the amp from the system and change the door speakers for the standard ones. (The wires and plugs for both systems are fitted to all cars.)

The standard system did not have the sub speakers in the parcel shelf, that are again connected to the amp in the boot.
So an aftermarket head unit will not work the sub speakers, only the door speakers using the standard speaker wires.

In short in an S-type with the premium sound amp in the boot fitting an aftermarket head unit is not easy at all.

Did your original head using have the touch screen or not? If it had the touch screen then the A/C is controlled through this screen so they will not work at all with an aftermarket head unit. You are however ok in this regard if your car did not have the touch screen.

Mellow
 

Dalgo

New member
Joined
Apr 4, 2021
Messages
8
Reaction score
1
Points
3
I appreciate that Mellow... guess it’s back to the drawing board to figure this out... side Note My brother has the exact same car as you (04 R) & I know he’s havingsome minor problems. I mights have some more questions pretty soon
 
Last edited:
Top