Jaguar Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hi, new to the forum!
i've just bought a 1996 xj6 4.0 sport and it has a couple of minor issues
first of all the alarm...
the previous owner gave me a key fob with the car but said it didnt work...
i tried about 300 times to reprogram the key, (open door, key on, valet x5) the lights flash after the 5th valet press but it makes no sound.
i press the button on the fob and it makes no sound and the fob still doesnt work? (the light on the fob works when you press the buttons.)
the fob is the two button one (lock bigger than unlock)
also the hazards flash once on unlock (with key in door) and twice when locking
the lights turn on (as in driving lights) when you unlock the vehicle and turn off when the key is turned in the ignition... any ideas?!?!?!

the gearbox... drives perfectly, selects reverse and drive fine...
but when you try to put it into the manual gears, (D, 3, 2) the gear lever will physically not move over to the left hand side of the J gate.
i refilled the automatic transmission fluid as it was low.
is this a common problem? it feels although the reason its not moving across is in the mechanism below the gearstick and not in the gearbox/cables. obviously not a major issue as i can still drive the car no problem but i'd like to fix it!!

also airbag light is on (how do i turn that off?)

any help or information will be greatly appreciated!!
many thanks. Mark.
 

·
Registered
Joined
·
14 Posts
The air bag light i believe has to be turned off with a code reader I believe, but an ECU reset may also do that. Take the terminals off of the battery and touch them together for 10 seconds for an ECU reset. Another member might be able to confirm this.

If you remove the gear selector housing see if something has fallen down and jammed the mechanism, thats all I can think it could be.

Sorry cannot help you about the key fob but my friend is having the exact same problem with his.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Tried ecu reset as described which did turn the airbag light off, it has come back on after driving the car though. I believe the car has been crashed and repaired in the past. Checked airbag fuses but yet to see if I actually have any air bags... Will pull the dash apart tomorrow. Replaced batteries in keyfob but still no luck. The alarm sounder was unplugged so now beeps when it should but would really like to get the keyfobs working as continually beeps till you put the key in the ignition after you unlock it!!
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top