Jaguar Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello all. I'm new to the X Type section, but I was a member in the XKR/X150 forum (when it was still a 'current model' :???:). Password issues aside, I'm now a 'new member', again.

- I have just bought a 3.0 2002 X Type SE automatic with 66,000 miles (DVLA/ MOT history checked) for a 4000 mile road trip. Long story short, I took a punt on an accident damaged car (cosmetic) and on the 150 mile drive home I noticed a few issues. I've tried the forum search function, but can't find anything relevant.

1 - Check engine light. Not so much the light itself, but the fact that my ELM327 bluetooth OBD reader wont connect. It works on my 2007 XKR fine, but not on this 2002 X Type. Any ideas ?
There is a list of codes in the glove box from an auto electrician dated last March, mostly O2 sensors and wheel speed / ABS sensor related, and B1582 "Dimmer lighting short to earth", B1676 "Battery voltage outside of nominal value", B2879 "Fuel Suction pump", and U1900 and U2603 CAN BUS "Instrument cluster function disturbed". The faults were apparently cleared at that time.

2 - Droning noise from the front end when moving, sounds like a cross between a playing card rubbing on bike spokes at low speed, and the turbo props on a Dash 8 at 70 mph. Rises and falls with road speed, not engine speed. Sounds slightly worse turning left. I'm hoping it's a wheel bearing and not a transfer case issue. It's not LOUD loud, but loud enough.

3 - Kick down, hmmm, as soon as the pedal 'clicks' down the car accelerates well but produces *lots* of white 'smoke' from both exhausts. As soon as I lift off it stops immediately. It's not using any water. My co-pilot for the road trip was following in another car and he says it's not oil smoke, as it's white and odourless. It could be condensation / rain / moisture in the tail pipes, as it's sat for at least 2 months, but then again it could be something a lot more serious.

4 - Faint but annoying buzzing behind the dash, with ignition on or off, locked or unlocked.

Apart from that, it's a peach! :mrgreen:
It's booked into the local garage next week (proper 'old school' mechanics), but I thought I'd ask the forums opinion on what may be X Type specific issues.

Thanks in advance.
 

·
Registered
Joined
·
1,317 Posts
1) some code readers don't like x types, I have a couple and one wont communicate ever.

2) Droning noise possibly a wheel bearing (check for play side to side top and bottom), or like you've said something rubbing!

3) smoke could be condensation especially at this time of year.

4) Buzzing behind the dash could be the ambient temp sensor fan (try blowing it out with a can of air)
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks Sean

Update:
1 - 'Operator error'. It's working just fine, P1647.
2 - It was a wheel bearing.
3 - It must have been condensation, but I have never seen anything so extreme in 25 years of driving.
4 - Radio drowns it out!

Garage changed the wheel bearing last week. I did the O2 sensor on Saturday and took it for a spin (610 mile round trip to Silverstone), 28 mpg playing with it on the way down, 32 mpg behaving on the way home. Didn't miss a beat, lovely to drive apart from the underwhelming brakes.

It was actually bought for a 'banger rally' (Edinburgh - Rome via Switzerland) but I'm sorely tempted to make it my 'daily driver'.
 

·
Registered
Joined
·
1,317 Posts
Thanks Sean

Update:
1 - 'Operator error'. It's working just fine, P1647.
2 - It was a wheel bearing.
3 - It must have been condensation, but I have never seen anything so extreme in 25 years of driving.
4 - Radio drowns it out!

Garage changed the wheel bearing last week. I did the O2 sensor on Saturday and took it for a spin (610 mile round trip to Silverstone), 28 mpg playing with it on the way down, 32 mpg behaving on the way home. Didn't miss a beat, lovely to drive apart from the underwhelming brakes.

It was actually bought for a 'banger rally' (Edinburgh - Rome via Switzerland) but I'm sorely tempted to make it my 'daily driver'.
A lot of people complain of poor brakes, I changed my discs and pads to pagid front and rear, serviced all four calipers changed the brake fluid. Mine will almost stand on its nose if you need it to. Fantastic brakes. I also have decent tyres blown up to the correct pressure.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top