Jaguar Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

I have a 58 plate 2.7 Premium Luxery XF. Recently for the first time ever (I've had it 3 years now), I got a warning message come up on the dashboard saying "washer fluid level low". I topped it up to full, tested the washers and they worked fine. Warning went out for a few days then reappeared. Water level is full, washers/wipers work fine but can't get rid of the annoying warning message. Pain in the neck as it overwrites the clock display. If the car has been stood for a while it does not appear when first started but comes on after five to 10 minutes of driving. Anyone any ideas for a solution? Would be much appreciated.
 

·
Premium Member
Joined
·
23,827 Posts
Sensor or wiring to it would be my first thought.
 

·
Premium Member
XJ Autobiography
Joined
·
695 Posts
Hi,
....Pain in the neck as it overwrites the clock display.....
Did you know you can temporarily get rid of the warning message so that the clock appears again. Touch the warning triangle on the touchscreen, a pop-up message appears asking if you wish to delete the warning. touch "yes", the message disappears and the clock re-appears along with a small warning triangle next to the clock, ...until the next ignition cycle. It won't cure the fault but you will have the clock back.
 

·
Registered
Joined
·
442 Posts
I had the same happen to my XF. I cleaned the contacts and it cured the problem for a short period but it came back on so I disconnected the darned thing altogether. It’s easy to know when you need a top up without relying on sensors which just corrode.
 

·
Registered
Joined
·
3,167 Posts

·
Registered
Joined
·
2,101 Posts

·
Registered
Joined
·
1,499 Posts
I've been getting the low screen wash message on mine for some time and have tended to ignore it or do the temporary thing with the triangle. Strangely a couple of weeks ago the message dissappeared and has not come back as yet, no idea why except the temperature is getting colder?
 

·
Registered
Joined
·
31 Posts
Hi,

I have a 58 plate 2.7 Premium Luxery XF. Recently for the first time ever (I've had it 3 years now), I got a warning message come up on the dashboard saying "washer fluid level low". I topped it up to full, tested the washers and they worked fine. Warning went out for a few days then reappeared. Water level is full, washers/wipers work fine but can't get rid of the annoying warning message. Pain in the neck as it overwrites the clock display. If the car has been stood for a while it does not appear when first started but comes on after five to 10 minutes of driving. Anyone any ideas for a solution? Would be much appreciated.
Hi, I had the same problem with mine, as well as water leaking out, which I discovered to be the rubber seal round the Sensor.
The leaking screen wash had corroded the connections thus causing the fault. I replaced it with a Ford one, the exact same form fleBay for only £6.51 inc del...:-D
See link below, Hope this helps as I know these cause problems...

https://www.ebay.co.uk/itm/Windscre...222308&hash=item2f05c181d1:g:aCgAAOSwq~tZSQS3
 

·
Registered
Joined
·
3,167 Posts

·
Registered
Joined
·
31 Posts
Yep, I just pulled the inner plastic arch slightly to the side. Did not bother taking wheel or inner off...😕
Then the float switch just pulls out of rubber grommet after you disconnect the wire plug.
Make sure it goes back in the correct way up! 🤔
Only took around 10 minutes....👍
Hope this helps, cheap fix at £6.51...😁😁😁
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top