Jaguar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hi to all, I need help with x type 03 2.1 problem. air recycle/air con, front and rear screen heaters and heater direction flaps have all stopped working. all fuses and relays seem ok. any pointers to help me would be gratefully received as am running out of hair. many thanks.
 

·
Premium Member
Joined
·
23,827 Posts

·
Premium Member
Joined
·
23,827 Posts
Hi Anthony, the feeds for the module are fuse F75 7.5A and F80 7.5A and F99 10A All in the central junction fuse box. Your problem does point to either a module problem or supply to it.

Check the 3 fuses above and we can go from there.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
hi again jim, I have removed glove box (again) to check f75,f80 and f99, all are ok. I ran engine till hot and put heater fan on full and checked if these fuses had any voltage but none there, (I used separate earth direct from battery) if you have any other suggestions I could try I would be very grateful. many thanks
 

·
Premium Member
Joined
·
23,827 Posts
Hi Anthony, it would be almost impossible to not have any power at all on those 3 fuses. Please check fuse F2 50A in the power distribution box.
Without seeing the car it’s difficult to find the problem as with no power to those 3 fuses there would probably be a lot more not working.
 

·
Registered
Joined
·
1,317 Posts
Not trying to tell you how to suck eggs mate, far from it, however have you actually tested the fuses with a continuity tester? or have you just inspected them?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top