Battery

Mr Squirrel

Member
Joined
Mar 18, 2012
Messages
699
Reaction score
1
Points
18
Location
Saaaf Yorkshire
Hi folks. I know this question will have been covered before but i would still like some personal opinions.

I am still very much enjoying life with my new to me 2010 3.0D X250 that i bought in September. All is thankfully very well with no issues and long may this trend continue. However, when i bought the car, for a week or so, i had a flash of low battery on start up (understandable as it had been stood a while) but over time, that has gone away until this week when the temperature dropped. Still starts and runs ok - so no issue really but i checked the battery physically and saw that it is the original! (at least has the Jaguar decals) so i am considering replacing it for the sake of preventative maintenence and here are my questions....

Question 1: I am looking at a Yuasa YBX5019 12V 100Ah 900A Silver High Performance Battery
Suitable and any good?

Question 2: Does this need 'coding' to the car?

I ask these questions as i have seen contradictory remarks elsewhere but you guys have never done me wrong so i trust your advice. :)
(and its easier to blame you if that advice sucks!) ;)
 

philayl1

Active member
Joined
Jan 16, 2014
Messages
1,724
Reaction score
9
Points
33
Location
Wirral, Merseyside
Suggest you get the battery condition monitor reset, it doesn't always recalibrate itself despite what some people say, my first two battery changes did, but the last one wouldn't reset even over a couple of months. Phil
 

MrKis

Senior member
Joined
Jun 8, 2009
Messages
3,201
Reaction score
256
Points
98
Location
Manchester UK
Suggest you get the battery condition monitor reset, it doesn't always recalibrate itself despite what some people say, my first two battery changes did, but the last one wouldn't reset even over a couple of months. Phil
How do you tell if it has reset?
 

philayl1

Active member
Joined
Jan 16, 2014
Messages
1,724
Reaction score
9
Points
33
Location
Wirral, Merseyside
On mine it with the last battery it cut the radio off when parked after 3 minutes without the reset, after the reset it would go over 10 mins without cutting off. Phil
 

Jimbov8

Senior member
I Have Donated !
Joined
Apr 5, 2013
Messages
15,161
Reaction score
1,345
Points
178
Location
Worksop
On mine it with the last battery it cut the radio off when parked after 3 minutes without the reset, after the reset it would go over 10 mins without cutting off. Phil
If you have the ignition on whilst listening to the radio you get 3 minutes, if you have the ignition off whilst listening to the radio you get 10 minutes. That’s how mine is. ;)
 

philayl1

Active member
Joined
Jan 16, 2014
Messages
1,724
Reaction score
9
Points
33
Location
Wirral, Merseyside
If you have the ignition on whilst listening to the radio you get 3 minutes, if you have the ignition off whilst listening to the radio you get 10 minutes. That’s how mine is. ;)
The ignition was off on both occasions, hence the noticeable difference. Phil
 
Top