Jaguar Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Hi everyone, anyone had this happen to them?
Drove the XK this morning all fine....parked it up for a couple of hours and on starting it up noticed the climate wasn’t working. The climate icon on the touch screen was greyed out and I couldn’t work anything (heating, seats, heated steering wheel). Everything else is working fine. Very strange!
Rang my Indy jag man and he said they can do this occasionally and to wait an hour and try again and if that doesn’t work then disconnect the negative terminal on the battery for 5 mins. If it persists he said there’s a software update that I’ll have to get done at the dealer that will fix it. Takes a couple hours.
Wifes got the car this afternoon so haven’t been able to check if it’s cleared itself yet.

Has anyone else had this issue or had the software update done?

Phil
 

·
Premium Member
Joined
·
23,827 Posts
Had the same when I first got the car, fully charged the battery and been maintained ever since with no further problems. Always worth checking the battery voltage first in case it is a little on the low side. It doesn’t take a big drop before strange things start to occur.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #3 ·
That’s good to know thanks Jim.
It’s home and seems to have rectified itself thankfully. It’s always hooked up to a ctek too so will see how it goes.
 

·
Registered
Joined
·
4 Posts
Phil
did you find a solution to battery problem. My XKR 2007 4.2 needed new battery and aircon stopped working afterwards, everything else has reset. The touch screen works but no reponse from the system. Dont really wNt to take it Carrs but will if a software upgrade is needed
graham
 

·
Registered
Joined
·
1,967 Posts
Have you checked the fuse?

Hi everyone, anyone had this happen to them?
Drove the XK this morning all fine....parked it up for a couple of hours and on starting it up noticed the climate wasn't working. The climate icon on the touch screen was greyed out and I couldn't work anything (heating, seats, heated steering wheel). Everything else is working fine. Very strange!
Rang my Indy jag man and he said they can do this occasionally and to wait an hour and try again and if that doesn't work then disconnect the negative terminal on the battery for 5 mins. If it persists he said there's a software update that I'll have to get done at the dealer that will fix it. Takes a couple hours.
Wifes got the car this afternoon so haven't been able to check if it's cleared itself yet.

Has anyone else had this issue or had the software update done?

Phil
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top