Coil light limp mode

XX 57

New member
Joined
Jan 30, 2021
Messages
21
Reaction score
0
Points
1
Hi I've changed the maf and map sensor.cleaned the egr.but still in limp mode???
 

Billy2Jags

Senior member
Joined
Mar 14, 2016
Messages
5,525
Reaction score
61
Points
73
Location
Midlands, UK
I'd carefully check the plug and wiring to the MAP sensor.
Engine running and plug connected.
Pin 1 White/Green - T-MAP SENSOR PRESSURE SIGNAL, NOMINAL 0 – 5 V: VOLTAGE INCREASES AS MANIFOLD ABSOLUTE PRESSURE INCREASES
Pin 2 Yellow/Green - T-MAP SENSOR POWER SUPPLY: NOMINAL 5 V
Pin 3 White/Green - T-MAP SENSOR TEMPERATURE SIGNAL, NOMINAL 0 – 5 V: NTC SENSOR – VOLTAGE DECREASES AS TEMPERATURE INCREASES
Pin 4 Brown/Green - Ground
It's not uncommon for the wires to beak inside the insulation so check for continuity back to the ECU too.
 

XX 57

New member
Joined
Jan 30, 2021
Messages
21
Reaction score
0
Points
1
I'd carefully check the plug and wiring to the MAP sensor.
Engine running and plug connected.
Pin 1 White/Green - T-MAP SENSOR PRESSURE SIGNAL, NOMINAL 0 – 5 V: VOLTAGE INCREASES AS MANIFOLD ABSOLUTE PRESSURE INCREASES
Pin 2 Yellow/Green - T-MAP SENSOR POWER SUPPLY: NOMINAL 5 V
Pin 3 White/Green - T-MAP SENSOR TEMPERATURE SIGNAL, NOMINAL 0 – 5 V: NTC SENSOR – VOLTAGE DECREASES AS TEMPERATURE INCREASES
Pin 4 Brown/Green - Ground
It's not uncommon for the wires to beak inside the insulation so check for continuity back to the ECU too.
Hi your advice was spot on now looking for a map sensor pigtail done temporary fix out of limp mode
 

Billy2Jags

Senior member
Joined
Mar 14, 2016
Messages
5,525
Reaction score
61
Points
73
Location
Midlands, UK
Pretty sure the Ford part is the same if new part is needed.
Any idea where the break is so you can just splice in a new piece of wire?
 
Top