Jaguar Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
Sorry if this has been done before. I am quite confident in the actual replacement but its the draining and refilling I could do with some advice. Could somebody give me a few tips please? Also, does the bumper have to come off, and if so is it easy enough? I can see the unit down past the expansion tank, which I can remove, but the clips on the hoses look difficult at arms length! Do they come off reasonably easy, and are new ones necessary to refit?
Thanks for any advice.
 

·
Registered
Joined
·
2,292 Posts
Hi, i take it yours is a late 2002 onwards as you say its down under the expansion tank, so the valve has only got 3 pipes not 5 like the 1999-2002 ones.

How do you know its not working?

They are open (heat to heater) then engine off and close then climate is off or set to cold with engine running.

Then i got my late 2002 s type i had no heat (valve was stuck closed with radweld) and i replaced with good 2nd hand one and it then was open all the time (full heat), it turned out i had a fault in both wires from heater module to valve. As i understand sometimes then valves go faulty it can cause faults in the wire feds or/and burn a line out in the module.

So if you know the valve faulty - don't take bumper as the valve is behind the rad, drain coolant by the rad drain which is on the bottom right hand corner, remove expansion tank. If you look down at heater valve there is 1 bolt which is holding it in place, undo this and it will lift up a bit to make it easyer to undo pipes. You could if easyer remove the valve with the pipes (undo the other ends of pipes, i think the ones connecting to steel pipes have quick release ends).

Hope this helps!

Simon.
 

·
Registered
Joined
·
86 Posts
Discussion Starter · #3 ·
Thanks Simon.

3.0 2007 (used to have that in my signature thingy)

The air con stopped working, there was a sort of scraping noise for a while after when it was set to Lo but that stopped after a week or so, now just warm air blowing out. Fuses fine. I read a lot about heater valves being stuck etc so plan to try this next. I'm so far from a specialist and quite capable so I thought I would try this. Does that ring any bells?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top