Jaguar Forum banner
1 - 20 of 20 Posts

·
Premium Member
Joined
·
708 Posts
Discussion Starter · #1 ·
Yesterday and again this morning I've started the car (3ltr X350) and had the following:

* Speedo not working
* Temp gauge not working
* Rev counter not working

......in addition to the following messages:

* No DSC
* EPB error
* Gearbox Fault
* Low Brake Fluid
* EML light

If I stop and switch off/switch on then they all go away (except the amber EML that I'll have checked this week).

What on earth could it be?

:confused::confused::confused:
 

·
Premium Member
Joined
·
708 Posts
Discussion Starter · #3 ·
first thing to check is your battery followed by the dreaded earth points
Thanks desperate, I'll do that.

The car starts at the first touch of the key, so wouldn't a questionable battery show here first?
 

·
Registered
Joined
·
1,840 Posts
Not necessarily, a low battery will start the car but throw lots of spurious faults. It's a common problem on modern cars unfortunately.
Batteries normally last for around 5 years as a general rule.
It might however just need a good charge up.

Good luck with the EML.
 

·
Registered
Joined
·
3,108 Posts
How often is the car used, and how far is it driven?

I too would expect this to be due to low battery charge. I keep my XK on a battery conditioner if is is not being driven far for more than two days, and have no problems. Until I started doing this I had problems similar to those you describe.
 

·
Premium Member
Joined
·
708 Posts
Discussion Starter · #8 ·
Not necessarily, a low battery will start the car but throw lots of spurious faults. It's a common problem on modern cars unfortunately.
Batteries normally last for around 5 years as a general rule.
It might however just need a good charge up.

Good luck with the EML.
Thanks GR!! Just looked through the reams of invoices and the battery was replaced in 2013. I'll get it tested tomorrow.....

the earth points i would look at are the 2 behind the right hand side light and one on the left,seems to be another common fault with the 350
Cheers desperate - I'll check these first before I spend. Seems the XJ is a totally different animal to the X.....

How often is the car used, and how far is it driven?

I too would expect this to be due to low battery charge. I keep my XK on a battery conditioner if is is not being driven far for more than two days, and have no problems. Until I started doing this I had problems similar to those you describe.
Thanks Dave, this is really helpful. I only bought the car on Thursday last week so have no idea how often it was used before that; it was owned by a Dr so maybe only short journeys to & from surgery?!

Things at work are changing meaning I'll be working from home more/less driving, so a conditioner is a great idea :)
 

·
Registered
Joined
·
352 Posts
the great thing about this car is they all have the same faults ,if you find a problem you can bet 20 others here have had the same problem so fixing it is very easy here,this forum has been priceless to me
 

·
Registered
Joined
·
3,108 Posts
Things at work are changing meaning I'll be working from home more/less driving, so a conditioner is a great idea :)[/QUOTE]
I have the CTEK 10, which has served me perfectly for the last three years. These cars use a fair bit of battery power even when they are parked up, and they hate even partially discharged batteries. It really is great to know that the battery is always fully charged: It gives a wonderful peace of mind!
 

·
Premium Member
Joined
·
6,566 Posts
I've been wafting about on low tyre pressures,

whilst pumping all 4 tyres up I noted the CTEK traffic light connector's blinking red light flashes faster when I'm drawing a load.

Check out my showthread around page 26 for how to fix the earth studs mentioned earlier.

They may look ok, don't be fooled, show them a spanner and one or all will shear off.

Rich
 

·
Registered
Joined
·
1,770 Posts
Certainly it will be well worth while checking the earthing points at the front of the car. It is these that suffer corrosion from salt-laden air via the radiator grill. Be careful as people have had the aluminium nuts on the aluminium earth stud just fall off when a spanner is put on them. If this happens a new stud must be fixed somewhere near the original. So do be prepared and if you need the car on the Monday, make sure you have another car available !! I have never suffered either with previous X350 Sport, or my current X358. For the X350, I inspected these earths very early on and applied anti-corrosion fluid, and have done the same with the current car. Incidentally, I never had to replace the battery which was on the car when purchased in 2010 and still on it when I part-exed it last year.
 

·
Registered
Joined
·
1,225 Posts

·
Premium Member
Joined
·
708 Posts
Discussion Starter · #16 ·
Guys I can't thank you all enough for taking time to reply.....

I had the battery tested today and sure enough it's pretty much at the end of it's life (4yrs old). I have an hours drive tomorrow to have a couple of S/S mid-sport rear boxes fitted, so this'll give it a nice charge before I have it tested again, although I know I need a new one. I'll definitely check the earthing points as a back up.....

Thanks again everyone - as ever this forum & its' members have come up trumps again :-D

James
 

·
Registered
Joined
·
1,770 Posts
I never had any battery problems with my previous X350, a 2003 Sport. The battery it came with when I bought it in 2010 was still on the car and OK when I part-exed it in October 2016.
 

·
Registered
Joined
·
352 Posts
i wouldn't just check them mate,i would re drill and bolt them when you get the time,the original fixing was way too small for the job and its only a matter of time before electrolysis takes its toll on those tiny fixings
 

·
Registered
Joined
·
1,270 Posts
I had this too. The battery was usually okay, but if I didn't use the car for more than a week it would throw a 'DSC Unavailable'. Go 100 yds, stop, switch off, switch on, restart and it was gone.

Then I got a CTEK 3.8 and it's never happened since.
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top