S mode and gear box malfunction

Stefano

New member
Joined
Jul 21, 2021
Messages
2
Reaction score
0
Points
1
Location
Luxembourg
Hello I am new in this forum and a new owner of a great XKR convertible 4.2l year 2004. I have a problem with my gear box. After few km at high speed (200Km/H) and also using the "J" stick in manual mode and back to D, the "S" mode is no more available, the gear box cannot be operate manually any more, and the letter "D" is flashing... I have to switch off the engine, cool a bit, and start again. By using the car in town, the problem does not happen or rarely. I live in Luxembourg, and here at my place the Jag dealer has no clues what it could be... what do you think about this issue ? Thank you
 

thebiglad

Senior member
Joined
Aug 15, 2012
Messages
1,366
Reaction score
176
Points
78
Location
Central France
Hi Stefano and welcome to the forum. It's a good idea to introduce yourself in the 'new member ' section.

It sounds to me like the autobox oil is either low or in need of replacement. If I were you I would change the oil, filter and the electrical plug seal.

Dave
 

Stefano

New member
Joined
Jul 21, 2021
Messages
2
Reaction score
0
Points
1
Location
Luxembourg
Hi Stefano and welcome to the forum. It's a good idea to introduce yourself in the 'new member ' section.

It sounds to me like the autobox oil is either low or in need of replacement. If I were you I would change the oil, filter and the electrical plug seal.

Dave
Hi Dave, thank you for your advice. Yes I also think it is a good idea to completely change these parts before starting an expensive investigation and tests performed by mechanics...
I could not find the place in the "new member" section where I can introduce myself, but for sure I will find the way......
 
Top