Jaguar Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
I have had a new set of wiper blades fitted, the whole lot not just the rubbers.

But they are rubbish, they are loud as the rubber rubs against the screen and as a result just smear over the screen.

The blades are jag parts and I have had the same problem in the past.

The question!!!

Is there a way to resolve this.... maybe by reducing the pressure on the screen from the blade or something like this?

It cannot be that the blades are poor because they are new parts and I have seen this problem before.
 

·
Registered
Joined
·
898 Posts
jadodd
never been in an S-type yet that has completely quiet wipers, especially during light rain, that's why you have the intermittent speeds, I don't think reducing the pressure on the screen will help as the noise comes when the blade jumps across the screen.
merlin
 

·
Registered
Joined
·
10,079 Posts
Jaguar branded wiper blades and arms are TRICO. "Made in Mexico to Jaguar specification". I bought mine from the local Asian car spares shop, half the main dealer price.
Noise? it could be that the screen is contaminated. It might look clean but you'd be surprised at the c rap that's on there. I give mine a good clean with a dilute household ammonia solution, the something like Nilsil. Seems to work well on mine.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top